Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23518 - [pam] PKGBUILD of pam 1.1.3-1 limits @audio to -10 when pulseaudio uses -11 by default

Attached to Project: Arch Linux
Opened by Kristoffer Tidemann (ktide) - Wednesday, 30 March 2011, 16:22 GMT
Last edited by Jan Steffens (heftig) - Monday, 12 November 2012, 00:52 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

PKGBUILD of pam adds the relevant lines to limits.conf:
http://projects.archlinux.org/svntogit/packages.git/tree/pam/repos/core-i686/PKGBUILD

As such, pulseaudio is presumably unable to function in the way intended by upstream.
This task depends upon

Closed by  Jan Steffens (heftig)
Monday, 12 November 2012, 00:52 GMT
Reason for closing:  Not a bug
Comment by Kristoffer Tidemann (ktide) - Wednesday, 30 March 2011, 16:25 GMT
Oh, I fail at reporting bugs in the right category. I'm sorry.
Comment by Jan Steffens (heftig) - Wednesday, 30 March 2011, 19:42 GMT
pulseaudio uses rtkit, it does not depend on the audio group.
Comment by Jan de Groot (JGC) - Thursday, 31 March 2011, 09:05 GMT
This would only have influence if you're member of the audio group. Consider this: you don't need to be member of the audio group, only if you want to use the "realtime scheduling" that it allows you to do (big DoS hole imho). If you want realtime scheduling and direct access to the audio device, why would you use pulseaudio then?
Comment by Alexander F Rødseth (xyproto) (trontonic) - Sunday, 11 November 2012, 21:19 GMT
Is this still an issue?
Comment by Jan Steffens (heftig) - Monday, 12 November 2012, 00:51 GMT
A PulseAudio user should not be in the audio group, as PA depends on losing access to the audio device when the active session switches in order to hand over the device to the newly active session. PulseAudio asks rtkit to alter its scheduling parameters.

Loading...