Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23484 - [xfce4-genmon-plugin] latest 3.3.0-1 update is broken

Attached to Project: Arch Linux
Opened by Ciriaco Garcia de Celis (cgarcia) - Monday, 28 March 2011, 20:11 GMT
Last edited by Andrea Scarpino (BaSh) - Monday, 09 January 2012, 14:05 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

When xfce4-genmon-plugin 3.3.0-1 applet is added to the panel, it works properly.
However, when the user exits the account and logins again, only a label is shown. The command is never executed (at least for more than one hour).
Bug tested in a clean desktop (new user account created, no previous configuration existing).

Solution:

Reverting to previous 3.2-2 restores the correct function.

Additional details:

Showing the applet properties and clicking "cancel" also restores the proper function. However, this is required to be manually done after each login. And this is only possible if the applet has a label (otherwise, the user can only remove it thanks to the panel items list, or by killing the process). Perhaps the monitor does not properly schedules the command execution after starting (except when just added to the panel), regardless it is set to the default 30 seconds or to 1 second.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Monday, 09 January 2012, 14:05 GMT
Reason for closing:  Fixed
Additional comments about closing:  xfce4-genmon-plugin 3.3.1-1
Comment by Jesse Frey (jessef) - Wednesday, 30 March 2011, 16:43 GMT
with xfce4-panel 4.8.2 you can get to the properties even if the applet has no label through panel preferences.
also restarting the panel (xfce4-panel -r ) causes applet to disappear again.

I added a bug on the xfce bug tracker before I found this one:
http://bugzilla.xfce.org/show_bug.cgi?id=7449
Comment by Rosario Contarino (the_shade) - Thursday, 28 April 2011, 22:12 GMT
I fix that with this patch.
Comment by Greg (dolby) - Thursday, 28 April 2011, 22:48 GMT
Whats the source of this patch? Has it been submitted (and possibly included) in the upstream sources tree?
edit: Nevermind you have already added it in the bug report. Thanks!
Comment by Rosario Contarino (the_shade) - Thursday, 28 April 2011, 22:51 GMT
I made this patch. I just post it also on xfce bugzilla.
Comment by John Lindgren (jlindgren) - Monday, 02 January 2012, 15:26 GMT
This is fixed in upstream 3.3.1.

Loading...