Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23456 - [xmlto] Failed to load network entity.

Attached to Project: Arch Linux
Opened by James (JRMoore) - Saturday, 26 March 2011, 18:51 GMT
Last edited by Giovanni Scafora (giovanni) - Friday, 01 April 2011, 00:52 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Giovanni Scafora (giovanni)
Architecture i686
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Some packages may fail to build if xmlto is installed in the system, mpd for example fails with this error output:

/usr/bin/xmlto -o doc/protocol --stringparam chunker.output.encoding=utf-8 html doc/protocol.xml
I/O error : Attempt to load network entity http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl
warning: failed to load external entity "http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl"
compilation error: file /tmp/xmlto-xsl.PMd1eU line 4 element import
xsl:import : unable to load http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl

I verified that that chunk.xsl file is accessible so I think it may be a problem in xmlto not being able to download it. Maybe a missing perl dependency?
This task depends upon

Closed by  Giovanni Scafora (giovanni)
Friday, 01 April 2011, 00:52 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Thursday, 31 March 2011, 10:02 GMT
This is not a bug in xmlto. Xmlto calls xsltproc with --nonet, so it won't go online to fetch DTDs, XSL and XML files. To fix your case, you need to install docbook-xsl. Some packages rebuild the documentation with xmlto installed on your system. As build chroots don't contain xmlto unless it's in makedepends, I don't consider this a bug.

Loading...