Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#23453 - [qemu] Enable spice support

Attached to Project: Arch Linux
Opened by Josh Adams (rigormotis) - Saturday, 26 March 2011, 16:24 GMT
Last edited by Tobias Powalowski (tpowa) - Tuesday, 08 October 2013, 07:23 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 30
Private No


Since the most recent builds of virt-manager and associated tools have added support for using the spice protocol to talk to guests, it makes sense to enable spice support when building qmeu-kvm. Currently, if you try to use Spice instead of VNC as the display server a traceback pops up saying that the qemu-binary does not have spice support enabled.

Enabling spice support should be as easy as adding "--enable-spice" to the configure options in the PKGBUILD. I did a quick test doing just this and I was able to use Spice instead of VNC when working with virt-manager. Please note that I could not view the vm from within virt-manager, as it requires spice-gtk, which arch does not have a package for at the moment. However, I was able to view the VM using another spice client.

Additional info:
* package version(s)
qemu-kvm 0.14.0-1
* config and/or log files etc.

Steps to reproduce:
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Tuesday, 08 October 2013, 07:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  qemu-1.6.0-6
Comment by Tobias Powalowski (tpowa) - Saturday, 26 March 2011, 17:23 GMT
There is no spice library in arch yet.
Comment by Josh Adams (rigormotis) - Saturday, 26 March 2011, 19:45 GMT
Ahh, forgot that I had to build that myself. Do you know of any plans to add it? Supposedly, this is what Fedora/Red Hat will be using by default for VM's.
Comment by Tobias Powalowski (tpowa) - Saturday, 26 March 2011, 20:53 GMT
Send me links or PKGBUILD and no problem, support will be added.
Comment by Josh Adams (rigormotis) - Tuesday, 29 March 2011, 16:36 GMT
Alright, I've created the necessary PKGBUILDS (should be attached to this post) and done some initial testing and everything seems to work. The xf86-video-qxl driver should allow for Arch guest VM's to have some level of accelerated graphics, however there seems to be some upstream issues with using qxl driver in virt-manager at the moment, so I was unable to test this.

For spice, spice-protocol and xf86-video-qxl, I updated some outdated PKGBUILDs from aur:
- Spice -
- Spice protocol -
- xf86-video-qxl -

I did spice-gtk myself and added the following changes to the qemu-kvm PKGBUILD:
- Added spice as a dependency
- Added 'hda' to the --audio-card-list in the call to configure (This was unrelated to spice. It seems to be the default card that the new version of virt-manager uses.)
- Added --enable-spice to the call to configure

The only other change that needs made is to add spice-gtk as a dependency of virt-manager and I think that should take care of everything.

Hope you can use this stuff, first time making PKGBUILDs.
Comment by Josh Adams (rigormotis) - Tuesday, 29 March 2011, 16:39 GMT
Forgot to mention the issue with celt. Currently, spice requires an older version of Celt to build. There is an aur package for it here:

I know there already is a newer version of Celt in the community repo's, so I'm not sure how this should be handled.
Comment by Josh Adams (rigormotis) - Tuesday, 05 April 2011, 15:07 GMT
Any update on this? I think I provided everything needed to make a package with Spice support.
Comment by Josh Adams (rigormotis) - Tuesday, 05 April 2011, 17:08 GMT
Accidental double-post. Please ignore
Comment by Tobias Powalowski (tpowa) - Wednesday, 06 April 2011, 18:01 GMT
Well pay me a million dollar and i do it immediatly ;).
Sorry i'll add it when i have the time to do it.
Normal life consumes my time at the moment.
Comment by Josh Adams (rigormotis) - Wednesday, 06 April 2011, 18:17 GMT
No problem, I was just worried that this had been forgotten since I had made it a low priority bug.

Thanks for the update.
Comment by Josh Adams (rigormotis) - Wednesday, 04 May 2011, 17:16 GMT
Updated the qemu-kvm PKGBUILD to pull in patches that were added to the qemu-kvm package in Fedora 15 to get qxl drivers working properly in guests, providing 2d acceleration.

Comment by Josh Adams (rigormotis) - Wednesday, 04 May 2011, 17:29 GMT
Just realized that there was an update the the spice library, so I updated the PKGBUILD for that now too. Ignore the previous attachment, I could not delete it for some reason.
Comment by Tobias Powalowski (tpowa) - Tuesday, 17 May 2011, 11:54 GMT
as long as packages will conflict each other i cannot add this.
Comment by Tony Winters (wintersa) - Tuesday, 17 May 2011, 22:29 GMT
Spice works great with this xf86-video-qxl-0.0.13 driver! and qemu-kvm 0.14.0-1
virt-manager with spice enabled works to, a few bugs exist. But that's for the developers of virt-manager. I will report the bugs.
As mentioned before, spice-gtk is required for virt-manager to work with spice. After install spice-gtk I had to restart the libvirtd deamon. Maybe a idea to create an new AUR? pkgbuilds related to the xf86-video-qxl are out of date.

Thanks again for this packages, I`m very impressed of spice!
Comment by Jelle van der Waa (jelly) - Wednesday, 08 June 2011, 19:01 GMT
It would only be usefull to spice , spice-gtk would be moved into extra or community (tobias if you get the support i would be able to maintain it in [community] that is spice/spice-gtk)

sadly spice depends on celt0.5.1 and cegui-0.6, currently there are already two versions in [community]. Anyway spice looks cool ;)
Comment by György Balló (City-busz) - Friday, 07 September 2012, 21:32 GMT
I attached the up to date and stable sources to build qemu-kvm with spice support. libcacard and usbredir are optional build dependencies. (I'm unsure about their importance, probably USB redirection support would be a useful feature.)

If qemu-kvm is built with spice support, I'll be able to move and maintain GNOME Boxes and it's dependencies (libvirt-glib, spice-gtk and libosinfo) in the [community] repository.
Comment by Jelle van der Waa (jelly) - Saturday, 08 September 2012, 10:48 GMT
City-Busz, spice still has those annoying celt0.5.1 and cegui-0.6 deps.
Comment by György Balló (City-busz) - Saturday, 08 September 2012, 11:30 GMT
- cegui-0.6 is only an optional dependency, which is required for the internal client of Spice, but it's not needed for use spice with virt-manager and GNOME Boxes, so we can ignore this.

- celt051 is required of course, but it's a really small library, and it uses a different library name (libcelt051), so it does not conflict with other celt packages.
Comment by Kerrick Staley (KerrickStaley) - Friday, 28 December 2012, 12:01 GMT
I filed this bug:

I don't know how rigid the Spice protocol is; celt051 may be a hard requirement for a while.
Comment by Adrian (adirat) - Tuesday, 07 May 2013, 04:42 GMT
Any update on this?
Comment by Joan Rieu (Fififox) - Wednesday, 10 July 2013, 17:16 GMT
Since the spice package is now in the repositories, could the --enable-spice flag be added to the PKGBUILD to close this issue?
Comment by Maik Broemme (mbroemme) - Thursday, 18 July 2013, 19:49 GMT
I vote for it too as it is already the fastest way for running Windows via QEMU
Comment by Adam Dagan (adam777) - Tuesday, 23 July 2013, 19:32 GMT
Same here, using Spice to run XP, and the long compilation time for the AUR package keeps reminding me why not to opt for a source based distro...
Comment by Maik Broemme (mbroemme) - Tuesday, 23 July 2013, 20:27 GMT
Beside this there is a good technical reason for using spice instead of any other QEMU emulated graphic card. It supports multi monitor setups with different resolutions and dynamic adjustment.
Comment by Jelle van der Waa (jelly) - Tuesday, 23 July 2013, 20:33 GMT
Spice is in [community] and not in [extra] where qemu lives and [extra] deps should live in [extra]
Comment by Marti (intgr) - Friday, 02 August 2013, 10:01 GMT
Well can you move Spice to extra then, please? :)
Comment by alex (kabolt) - Friday, 23 August 2013, 20:32 GMT
any update?
And: can't spice be an optional dependency (e.g. via patch)?
Comment by Dave Reisner (falconindy) - Friday, 23 August 2013, 21:25 GMT
Please learn how ELF dependencies work. DT_NEEDED isn't something that can be "optional".
Comment by Kerrick Staley (KerrickStaley) - Saturday, 14 September 2013, 00:26 GMT
Could we get qemu-spice (with provides=('qemu')) in [community]? IIRC this was how qemu-kvm worked before the KVM feature was mainlined.
Comment by alex (kabolt) - Sunday, 15 September 2013, 20:30 GMT
Couldn't you simply add the spice support, make a note that the community extra problem must be fixed and
fix the break with the convention later?
Comment by Maik Broemme (mbroemme) - Sunday, 06 October 2013, 20:50 GMT
Couldn't we follow Kerrick Staleys proposal? It sounds reasonable.