Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#23417 - makepkg replaced files with zeroes

Attached to Project: Pacman
Opened by Jan Heck (Zuiop) - Thursday, 24 March 2011, 20:06 GMT
Last edited by Dan McGee (toofishes) - Friday, 25 March 2011, 19:18 GMT
Task Type Bug Report
Category makepkg
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version 3.4.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When building yaourt0.10-1, I noticed that makepkg randomly replaces some files with zeroes.

After running makepkg in the extracted AUR tarball, some files in both $pkgdir and the resulting package consisted of only zeroes (binary zeroes, not ASCII). All files in $srcdir were checked and found ok (ASCII .sh files). In the attached testcase, this happened to alpm_backup.sh and alpm_query.sh in pkg/usr/lib/yaourt, but with every following run of makepkg -sif, other files in this directory were affected.

I'm not quite sure which further information is necessary, so feel free to ask.


Versions:
pacman 3.5.1-1
This task depends upon

Closed by  Dan McGee (toofishes)
Friday, 25 March 2011, 19:18 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Bug in brtfs/kernel/coreutils
Comment by Jan Heck (Zuiop) - Thursday, 24 March 2011, 20:31 GMT
Just to clarify, this is in no way limited to a single package -- it just happened to me again with evince-gtk.
Comment by Allan McRae (Allan) - Thursday, 24 March 2011, 22:55 GMT
Are you using makepkg directly? Whare are you building the packages? On what filesystem?
Comment by Jan Heck (Zuiop) - Friday, 25 March 2011, 11:13 GMT
Yes, I run makepkg directly. Packages are being build in my home directory. Filesystem is Btrfs v0.19.

I've now also run a simple test where I would copy one of the files in $srcdir manually with /bin/cp a thousand times, and none of the resulting files were corrupted.
Comment by Allan McRae (Allan) - Friday, 25 March 2011, 11:18 GMT
Ah... bug in btrfs with the latest coreutils. I suggest you upgrade to kernel-2.6.38.
Comment by Jan Heck (Zuiop) - Friday, 25 March 2011, 11:22 GMT
Seems like it has to do something with the filesystem. My root partition is ext4. In a directory in / I build a few AUR packages with "sudo makepkg --asroot -sif" to see if that would change anything, and indeed all packages build there are fine.
Comment by Ionut Biru (wonder) - Friday, 25 March 2011, 11:28 GMT
@Allan care to elaborate? You know that we have btrfs on alderaan with all our chroots but i don't recall having this issue.
Comment by Allan McRae (Allan) - Friday, 25 March 2011, 11:32 GMT
compressed btrfs + coreutils-8.10 + kernel26 < 2.6.38 == fail.

Details in bug reports linked here: https://bbs.archlinux.org/viewtopic.php?id=113278
Comment by Ionut Biru (wonder) - Friday, 25 March 2011, 11:43 GMT
thanks. we are safe :D
Comment by Jan Heck (Zuiop) - Friday, 25 March 2011, 12:01 GMT
(double post)
Comment by Jan Heck (Zuiop) - Friday, 25 March 2011, 12:03 GMT
Sorry for the double post. And thanks for your help, very appreciated.
Comment by Dan McGee (toofishes) - Friday, 25 March 2011, 18:51 GMT
We can close this then?

Loading...