Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23414 - [perl-curses] Bug in module since upgrade to ncurses 5.8

Attached to Project: Community Packages
Opened by David Rosenstrauch (darose) - Thursday, 24 March 2011, 15:19 GMT
Last edited by Sergej Pupykin (sergej) - Thursday, 24 March 2011, 21:45 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

One of the apps that uses perl-term-animation (asciiquarium in the AUR) no longer works since ncurses was upgraded to 5.8. Another user reports that the app works fine if you downgrade back to 5.7.

However, the error message that occurs when running asciiquarium seems to flag perl-term-animation as the culprit:

Can't call method "getmaxx" on an undefined value at /usr/share/perl5/vendor_perl/Term/Animation.pm line 495.

Seems like the animation module no longer works correctly with the new version of ncurses. Any idea for cause or fix?



Additional info:
* package version(s)

asciiquarium 1.0-2
perl-term-animation 2.4-4
ncurses 5.8-1

* config and/or log files etc.

none

Steps to reproduce:

Run asciiquarium. It failes with above error message.
This task depends upon

Closed by  Sergej Pupykin (sergej)
Thursday, 24 March 2011, 21:45 GMT
Reason for closing:  Fixed
Comment by Sergej Pupykin (sergej) - Thursday, 24 March 2011, 20:09 GMT
it looks like perl-curses bug:

use Curses;
$win = new Curses;
$win->addstr(10, 10, 'foo');
$win->refresh;

Loading...