Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23390 - [patch] kernel26 2.6.38-1 fails to boot because of infinite loop in radeon driver

Attached to Project: Arch Linux
Opened by John Lindgren (jlindgren) - Tuesday, 22 March 2011, 20:30 GMT
Last edited by Tobias Powalowski (tpowa) - Friday, 25 March 2011, 06:44 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

On some systems (mine for example), the 2.6.38-1 kernel fails to boot because of an infinite loop in the radeon driver. The bug is reported upstream at https://bugs.freedesktop.org/show_bug.cgi?id=35502. The commit which introduced this bug is http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=36868bda88b92ce8a9aa8b3ee2e0d1e0de09cc19. The patch is a very simple sanity check which should not have any side effects. I think this patch should be included in the kernel26 package before it migrates from testing.


Additional info:

System: Toshiba Satellite A305-6916
Video: ATI Radeon Mobility HD 3650

I can attach a kernel log of a failed boot if desired, but I do not think it shows anything useful.


Steps to reproduce:

1. Turn on the computer.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Friday, 25 March 2011, 06:44 GMT
Reason for closing:  Fixed
Comment by Ionut Biru (wonder) - Tuesday, 22 March 2011, 20:35 GMT
does it work with kernel 2.6.38-2?
Comment by John Lindgren (jlindgren) - Tuesday, 22 March 2011, 21:11 GMT
The patch applies to upstream kernel 2.6.38 sources. So, unless Arch introduced a conflicting patch with 2.6.38-2, which is highly unlikely, the patch will still work.
Comment by John Lindgren (jlindgren) - Tuesday, 22 March 2011, 23:09 GMT
Just noting that upstream author has updated my patch to catch another similar case.
Comment by Thomas Bächler (brain0) - Tuesday, 22 March 2011, 23:42 GMT
Link to the patch is: https://bugs.freedesktop.org/attachment.cgi?id=44731

Please update this report once it has been commited anywhere upstream.
Comment by John Lindgren (jlindgren) - Thursday, 24 March 2011, 22:41 GMT
Does 2.6.38.1-1 have this patch applied? Because it boots. While the latest git kernel from upstream (not the 2.6.38 stable branch but the main branch) still requires patching.
Comment by Bogdan (JokerBoy) - Friday, 25 March 2011, 01:08 GMT Comment by John Lindgren (jlindgren) - Friday, 25 March 2011, 01:09 GMT
Ah, wonderful, thank you.

Loading...