Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#23357 - [namcap] detect overlinked libraries

Attached to Project: Arch Linux
Opened by Allan McRae (Allan) - Saturday, 19 March 2011, 23:16 GMT
Last edited by Jan Steffens (heftig) - Saturday, 27 June 2015, 13:45 GMT
Task Type Bug Report
Category Arch Projects
Status Closed
Assigned To Rémy Oudompheng (remyoudompheng)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No


namcap should print a warning when libraries are overly linked.

e.g. none of these libraries need linked:

> ldd -u -r /usr/lib/
Unused direct dependencies:


This task depends upon

Closed by  Jan Steffens (heftig)
Saturday, 27 June 2015, 13:45 GMT
Reason for closing:  Implemented
Comment by Jan Steffens (heftig) - Tuesday, 04 June 2013, 04:25 GMT
Gave this a shot. Please review and merge.
Comment by Jan Steffens (heftig) - Wednesday, 10 July 2013, 17:11 GMT
Any comment? Rémy?
Comment by Jan Steffens (heftig) - Monday, 16 September 2013, 07:21 GMT
Bump. Please don't forget this.
Comment by Doug Newgard (Scimmia) - Saturday, 31 May 2014, 03:23 GMT
Did this ever get sent to the arch-projects mailing list? Maybe I'm wrong, but that would seem to be the correct place for this patch.
Comment by Jan Steffens (heftig) - Saturday, 31 May 2014, 14:37 GMT Comment by Kyle Keen (keenerd) - Saturday, 27 June 2015, 13:45 GMT
Applied in commit 228172a71ef