Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#23270 - [emacs] package shouldn't replace cedet

Attached to Project: Arch Linux
Opened by Jonathan Arnold (jdarnold) - Monday, 14 March 2011, 16:10 GMT
Last edited by Jürgen Hötzel (juergen) - Wednesday, 30 March 2011, 11:36 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jürgen Hötzel (juergen)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No


Description: The Emacs PKGBUILD says it replaces cedet but this is incompatible with JDEE, which require the cedet package and won't work with the bundled package. I think perhaps just a warning is needed, as there are plenty of packages that Emacs provides that can be overridden by similar standalone ones.

Additional info:
emacs 23.3-1

Steps to reproduce:
This task depends upon

Closed by  Jürgen Hötzel (juergen)
Wednesday, 30 March 2011, 11:36 GMT
Reason for closing:  Won't implement
Additional comments about closing:  CEDET is now part of Emacs. The purpose of the "replace" is to uninstall "cedet" from "community" : unity/any/cedet/

If your packages need a more recent/different Version of "cedet" I would suggest a package name like "cedet-bzr"

Comment by Bence Balint (kraxor) - Monday, 14 March 2011, 18:01 GMT
I believe this also breaks ropemacs. Don't really have time to investigate more, but since the update / replace, ropemacs fails to load.
Comment by Jonathan Arnold (jdarnold) - Monday, 14 March 2011, 18:12 GMT
I'm not so sure any more. Further investigation leads me to believe the cedet that comes with emacs & the cedet available in Community are the same one. I still do think it shouldn't delete any package currently installed.

Actually I ended up grabbing the cedet-bzr version, as there is an imenu bug in the cedet 1.0 that it fixes. Took more hacking though to get that to work.