Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23215 - upgrade of xf86-video-ati-6.14.0 and xorg-server-1.9.4-1 Corrupts display for Radeon x1250

Attached to Project: Arch Linux
Opened by David C. Rankin (drankinatty) - Thursday, 10 March 2011, 07:25 GMT
Last edited by Jan de Groot (JGC) - Monday, 07 November 2011, 15:11 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After update to xf86-video-ati-6.14.0 and xorg-server-1.9.4-1, X will start and you will see the normal display manager. However on login, after you either close the first 'tips' window or open a menu, the display pixelates and wraps arround the display. Example:

http://www.3111skyline.com/dl/suse/bugs/114/X/broken.jpg

I have experienced this exact same problem on Arch and opensuse. In Arch, downgrading to:

xf86-video-ati-6.13.2-2
xorg-server-1.9.3.901-1
xorg-server-common-1.9.3.901-1
xorg-server-utils-7.5-5

restores normal operation. I currently have my updates set to --ignore upgrade of these files to prevent breaking the display.

Since X and fluxbox or X and kde are running - there are no obvious errors in the Xorg.0.log file.

I have added the dmesg output to provide hardware information. What other information can I provide that would be helpful?


Steps to reproduce:
Update a box with Radeon X1250 card to xf86-video-ati-6.13.2-2 and xorg-server-1.9.3.901-1. Boot to display manager and log in. On first window open or close (sometimes in the greeter itself), the display pixelates and become unusable :(
   dmsg.txt (412.7 KiB)
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 07 November 2011, 15:11 GMT
Reason for closing:  No response
Comment by David C. Rankin (drankinatty) - Wednesday, 16 March 2011, 04:29 GMT
Guys, this may be libgl in addition to an xorg problem. It has been confirmed on other distros as well. Basically EXA is broken for ATI and XAA works, but no 3D and the gpu performance is slow. Additional details can be found on the opensuse bugzilla:

https://bugzilla.novell.com/show_bug.cgi?id=678264

As suggested in the above report, a workaround with XAA only is to modify the configuration in /etc/X11/xorg.conf.d/ and set:

Section "Module"
Disable "dri"
Disable "dri2"
EndSection

Section "Device"
Identifier "Default Device"

Driver "radeonhd"
Option "AccelMethod" "xaa"
EndSection
Comment by Jan de Groot (JGC) - Monday, 03 October 2011, 14:08 GMT
Is this still an issue with current versions of mesa, xf86-video-ati and xorg-server (preferably from testing)?

Loading...