Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23155 - [xf86-video-ati] drmRadeonCmdBuffer : -22 Error.

Attached to Project: Arch Linux
Opened by bogdan (nicknill) - Saturday, 05 March 2011, 21:05 GMT
Last edited by Allan McRae (Allan) - Saturday, 02 June 2012, 12:15 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Jan de Groot (JGC)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
When I try to start game (for now it's WarCraft under wine) i see an error
drmRadeonCmdBuffer: -22. Kernel failed to parse or rejected command stream. See dmesg for more info.
and game closes.
I have an Ati R100 videocard
OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI R100 (RV200 4C57) 20090101 AGP 4x x86/MMX/SSE2 TCL


All system is up to date.

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
Try to start WarCraft under R100 ati opensource drivers
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 02 June 2012, 12:15 GMT
Reason for closing:  None
Additional comments about closing:  Reporter does not have hardware anymore. No other response.
Comment by bogdan (nicknill) - Saturday, 05 March 2011, 21:12 GMT
Here is the lines in dmesg

[drm:radeon_cs_parser_init] *ERROR* cs IB too big: 16406
[drm:radeon_cs_ioctl] *ERROR* Failed to initialize parser !
Comment by Renata Abreu (Helljawz) - Sunday, 01 May 2011, 01:41 GMT
I'm having the same problem. Here is dmesg output:

[ 674.672134] [drm:radeon_cs_parser_init] *ERROR* cs IB too big: 16425
[ 674.672139] [drm:radeon_cs_ioctl] *ERROR* Failed to initialize parser !

Almost the same.
Comment by Greg (dolby) - Sunday, 01 May 2011, 01:58 GMT
With which kernel is this?
Comment by Renata Abreu (Helljawz) - Sunday, 01 May 2011, 02:02 GMT
kernel26-2.6.38.4-1
Comment by bogdan (nicknill) - Sunday, 08 May 2011, 20:25 GMT
Try to install driconf, and set software tcl. This is workaround.

I've created bugreport in freedesktop bugzilla
https://bugs.freedesktop.org/show_bug.cgi?id=36978
Comment by Allan McRae (Allan) - Saturday, 28 April 2012, 16:12 GMT
Status?
Comment by bogdan (nicknill) - Saturday, 28 April 2012, 16:28 GMT
I can't confirm or close it, because i haven't ati anymore

Loading...