Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23139 - Change package's name python3-numpy to python-numpy

Attached to Project: Arch Linux
Opened by Hector Mtz-Seara Monne (hseara) - Friday, 04 March 2011, 22:32 GMT
Last edited by Stéphane Gaudreault (stephane) - Thursday, 14 July 2011, 11:14 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Stéphane Gaudreault (stephane)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Description:
when the change of the official python distribution to python3 was made, It was said that all python 3 packages will be shiped without identification number. Python 2 packages instead will be shiped with a 2 to identify them. python3-numpy is the only package which does not follow this convention. Please change the name from python3-numpy to python-numpy.


Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Stéphane Gaudreault (stephane)
Thursday, 14 July 2011, 11:14 GMT
Reason for closing:  Fixed
Additional comments about closing:  python2-numpy-1.6.0-1 and python-numpy-1.6.0-1 in [testing]
Comment by Jan de Groot (JGC) - Tuesday, 08 March 2011, 10:02 GMT
This was done to make the change easier. At this moment nothing uses the python3 version of numpy, but several things depend on the python2 version. Changing these package names means a lot of dependencies will become broken, and even if we fix it, people will end up with a python3 numpy package on their system even if they don't use it.
Comment by Hector Mtz-Seara Monne (hseara) - Tuesday, 08 March 2011, 10:33 GMT
I'm aware about the issue of the dependencies. But sooner or later this issue will have to be solved. In the moment archlinux made python 3.x as default we knew that this will happen. Right now there is a mess of notation and this should be changed soon. In my opinion the sooner the better. Also it will be a great opportunity to upgrade some outdated package like python-scipy to python2-scipy which by the way has now a python 3 compatible version. In that moment it is difficult to identify from the repos which packages there are in which version without digging in the dependencies.

I rated the severity of this bug as very low and I still think in that way. But it does not mean it is not a bug and should not be corrected. Python3 starts finally to take off, let's help it by making working with it easier.
Comment by Lukas Fleischer (lfleischer) - Tuesday, 08 March 2011, 10:33 GMT
Well, if that had been fixed properly, all packages would have switched to "python2-numpy". Grepping my ABS tree, it seems like about 10 packages actually depend on "python-numpy" which is not way too much. The python3 python-numpy package remaining on peoples' systems shouldn't be a blocker - we always have such orphan packages if dependencies change and they can be detected/removed easily using `pacman -Qdt`.
Comment by Stéphane Gaudreault (stephane) - Tuesday, 05 July 2011, 00:41 GMT
@Jan : Any objection if I fix this (i.e rename package, bump version to 1.6.0 and update dependecies for both python2- and python3-) with the python 3.2.1 update ? There is no rebuild planned with this python update, but it is a good time to take care of our python packages :)

Loading...