Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23100 - [mkinitcpio] autodetection of root filesystem type (btrfs) fails if root is on subvolume

Attached to Project: Arch Linux
Opened by Thilo Berndt (schlehmil) - Wednesday, 02 March 2011, 12:58 GMT
Last edited by Thomas Bächler (brain0) - Thursday, 07 April 2011, 08:20 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Thomas Bächler (brain0)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Recently util-linux has been updated to version 2.19 and the output for btrfs filesystem with subvolumes in findmnt has been changed to also include the subvolume name in the output.

Example:

schlehmil@shiva:~$ findmnt -n -u -o source /
/dev/sda5[/root]

# root is the name of my subvolume

This breaks the autodetect install hook in /lib/initcpio/install/autodetect because "/dev/sda5[/root]" cannot be processed by /sbin/blkid at line 18. My current solution is to remove this line entirely and to findmnt directly to acquire the filesystem type. Actually I even do not know why this ha not been done in first place? I see no reason to use blkid? I attached a patch for mkinitcpio recent version 0.6.8-2.


Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Thomas Bächler (brain0)
Thursday, 07 April 2011, 08:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 0.6.9.

Re-closed after re-opening, as the new issue was unrelated.
Comment by Arvid Norlander (AnMaster) - Sunday, 13 March 2011, 09:19 GMT
I'm not sure if I'm hitting the exact same bug. I see the same message but since I don't use btrfs it might be a different bug. In my case I use ext4 on top of mdadm RAID1. The findmnt command in the original bug report outputs /dev/root for me, while blkid reports the device as /dev/md1. I don't seem to have any /dev/root symlink either, most confusing. The kernel line in my grub config (GRUB 1) has root=/dev/md1 listed.

My question thus is: is it the same bug or should I open a separate bug report?
Comment by Thomas Bächler (brain0) - Sunday, 27 March 2011, 12:57 GMT
I am applying this, hoping it doesn't cause new bugs.
Comment by Thomas Bächler (brain0) - Sunday, 27 March 2011, 13:15 GMT Comment by Eugene Markow (ejmarkow) - Thursday, 07 April 2011, 07:20 GMT
  • Field changed: Percent Complete (100% → 0%)
During March, 2011, I've been mkinitcpio to create my initial RAM disk image while manually compiling the kernel source and I'm getting the following error.

:: Parsing hook [autodetect]
ERROR: Root file system type detection failed.

Prior to around March, 2011, this was not happening. I use the Ext4 filesystem.
Comment by Thomas Bächler (brain0) - Thursday, 07 April 2011, 08:19 GMT
This is an entirely different bug, please open a new report.

Loading...