Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23096 - [grub] 0.97-17 fails to load os with quickboot enabled in bios using crucial real ssd.

Attached to Project: Arch Linux
Opened by adam (nemesis2all) - Wednesday, 02 March 2011, 05:26 GMT
Last edited by Ronald van Haren (pressh) - Thursday, 03 November 2011, 21:04 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Failure to load grub with quickboot enabled in bios using crucial real ssd firmware 0006. With quickboot enabled using grub 0.19-17 when loading os computer reboots with no warning message or error logs. Computer will boot without quickboot enabled. This bug effects 32bit and 64bit versions. This bug persists using a hdd to boot as long as the ssd is still connected. Quickboot works with same configuration using grub2.

Additional info:
Motherboard: Gigabyte p55m-ud4 firmware version F11
SSD: Crucial Real SSD firmware version 0006

* package version(s) grub 0.97-17

* config and/or log files etc. N/A


Steps to reproduce: Install arch linux with crucial real ssd firmware version 0006 on gigabyte p55m-ud4 motherboard. Enable quickboot in bios. Start computer.
This task depends upon

Closed by  Ronald van Haren (pressh)
Thursday, 03 November 2011, 21:04 GMT
Reason for closing:  Won't fix
Comment by Leonid Isaev (lisaev) - Saturday, 05 March 2011, 19:30 GMT
Please show us your /etc/mkinitcpio.conf and /boot/grub/menu.lst. Also, are there any relevant error (like firmware bugs) in system log after a successful boot? Other than that, you report suggets a BIOS/firmware bug.
Comment by adam (nemesis2all) - Saturday, 05 March 2011, 20:14 GMT
Those are the relevant files you requested. I do not believe I have any logs from it anymore. I switched to grub2-bios. I do not encounter the problem using grub2. I do believe you are correct tho that it is BIOS/firmware bug, hardware related, or a limitation of grub.
Comment by Anonymous Submitter - Friday, 12 August 2011, 08:51 GMT
Is this still a bug with "core/grub 0.97-20" ? Or if this is something that has been solved by using grub2 then this bug report can be closed since this may not be solved in grub-legacy (dead upstream for grub-legacy).

Loading...