Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#23089 - Removal of HAL deletes /media

Attached to Project: Arch Linux
Opened by Bigby James (ANOKNUSA) - Tuesday, 01 March 2011, 17:41 GMT
Last edited by Ionut Biru (wonder) - Sunday, 31 July 2011, 11:52 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Pierre Schmitz (Pierre)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Description: Upon upgrade to KDE 4.6, several users reported on the Arch Linux forums that they were unable to mount external devices. I myself found that my /media folder had been deleted, and the other users confirmed this. It's recently been confirmed by another user that removal of HAL is the cause of this. While the rest of the file system appears unaffected--and it appears this only happens when no devices are mounted--it is disturbing to see a core segment of the root fs get wiped.

Additional info:
* package version(s)
hal 0.5.14-6
* config and/or log files etc.

Steps to reproduce:

- Install extra/hal:

pacman -S hal

- Completely remove hal

pacman -Rns hal

Performing these steps while a device (e.g. flash drive) is mounted appears to negate this effect, leaving /media intact with the device still mounted.
This task depends upon

Closed by  Ionut Biru (wonder)
Sunday, 31 July 2011, 11:52 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#25141 
Comment by Greg (dolby) - Tuesday, 01 March 2011, 17:50 GMT
This is a pacman issue and "duplicate" of the closed bug reports  FS#11263  .
There was some discussion about this some days ago in the pacman-dev mailing list:
Comment by Bigby James (ANOKNUSA) - Tuesday, 01 March 2011, 17:56 GMT
Just sent my request for the mailing list subscription yesterday, and haven't gotten a reply yet; sorry for adding extra crap to the bug queue.
Comment by Greg (dolby) - Tuesday, 01 March 2011, 18:01 GMT
No need to be sorry. Bug reports are always welcome, especially when they're valid.
Also, both the bug reports mentioned in the email didnt solve this issue. Maybe the time is now:)
Comment by Leonid Isaev (lisaev) - Wednesday, 02 March 2011, 16:47 GMT
Just to clarify, the real problem is not so much pacman, but rather the hal package including /media, which is strange provided every arch installation is supposed to have the filesystem package installed. Fix is easy: remove /media from hal. The reason why not everyone, who erased hal, was affected is because hal creates a datafile /media/.hal-mtab, which prevented pacman from removing /media.

Since hal is going for deprecation anyway, I don't think this report has much relevance...
Comment by Ionut Biru (wonder) - Wednesday, 09 March 2011, 19:44 GMT
@Pierre, can you include /media in filesystem package?
Comment by Greg (dolby) - Wednesday, 09 March 2011, 20:17 GMT
@Ionut: /media IS in the filesystem package. Read the content of the links in my first comment.
Comment by Ionut Biru (wonder) - Wednesday, 09 March 2011, 20:26 GMT
uff, i didn't mean that. i mean to add a touch ${pkgdir}/media/.keep
Comment by Leonid Isaev (lisaev) - Wednesday, 09 March 2011, 21:05 GMT
Then, to be consistent, one has to do the same with /opt, /mnt, /usr/local/* ...
Comment by Jan de Groot (JGC) - Friday, 15 April 2011, 08:24 GMT
This bug will be triggered once more when we remove hal from the repositories.
Comment by Pierre Schmitz (Pierre) - Friday, 15 April 2011, 13:00 GMT
This looks more like a pacman bug to me.
Comment by Greg (dolby) - Friday, 15 April 2011, 22:38 GMT
Udisks which is the HAL replacement for automatic mounting doesnt seem to carry a /media dir so its not issue anymore for that dir. Are the any packages that mess with it?