Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23078 - [NetworkManager] connection sharing broken due to dnsmasq

Attached to Project: Arch Linux
Opened by Leontius Adhika Pradhana (leonth) - Monday, 28 February 2011, 17:44 GMT
Last edited by Gaetan Bisson (vesath) - Friday, 24 August 2012, 07:33 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Ionut Biru (wonder)
Jan Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
As stated. Related bug report for ubuntu: https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/725041


Package versions:
* networkmanager 0.8.3-0.20110113
* dnsmasq 2.57-1

dmesg:
Mar 1 01:38:54 leon-laptop NetworkManager[3585]: <info> Executing: /usr/sbin/iptables --table nat --insert POSTROUTING --source 10.42.43.0/255.255.255.0 --destination ! 10.42.43.0/255.255.255.0 --jump MASQUERADE
Mar 1 01:38:54 leon-laptop NetworkManager[3585]: <info> Starting dnsmasq...
Mar 1 01:38:54 leon-laptop NetworkManager[3585]: <info> (wlan0): device state change: 7 -> 8 (reason 0)
Mar 1 01:38:54 leon-laptop NetworkManager[3585]: <info> Activation (wlan0) successful, device activated.
Mar 1 01:38:54 leon-laptop NetworkManager[3585]: <info> Activation (wlan0) Stage 5 of 5 (IP Configure Commit) complete.
Mar 1 01:38:54 leon-laptop NetworkManager[3585]: <warn> dnsmasq exited with error: Configuration problem (1)
Mar 1 01:38:54 leon-laptop NetworkManager[3585]: <info> (wlan0): device state change: 8 -> 9 (reason 18)
Mar 1 01:38:54 leon-laptop NetworkManager[3585]: <warn> Activation (wlan0) failed for access point (abc)
Mar 1 01:38:54 leon-laptop NetworkManager[3585]: <warn> Activation (wlan0) failed.



Steps to reproduce:
In network manager, create a new wireless network. Then IPv4 Settings -> Method: Shared to other computers. The wireless network won't connect.
This task depends upon

Closed by  Gaetan Bisson (vesath)
Friday, 24 August 2012, 07:33 GMT
Reason for closing:  Upstream
Comment by speedyx (speedyx) - Monday, 14 March 2011, 17:40 GMT
I have problem with sharing connection with NetworkManager too, in KDE 4.6.1 on Chakra with the same packages. How to downgrade?
Comment by Greg (dolby) - Monday, 14 March 2011, 17:44 GMT
Chakra is a project of its own now. Report it to them.
Comment by Jeff Cook (cookiecaper) - Wednesday, 16 March 2011, 01:11 GMT
I'm getting this bug too on Arch Linux.
Comment by Vladimir (Psycho_zs) - Wednesday, 06 April 2011, 16:49 GMT
this is incompatibility of networkmanager with new dnsmasq.
current extra/networkmanager 0.8.3-0.20110113 is affected
Comment by Ionut Biru (wonder) - Sunday, 01 May 2011, 11:40 GMT
what about networkmanager-0.8.998-3?
Comment by Ionut Biru (wonder) - Wednesday, 19 October 2011, 14:19 GMT
is there anything else here to do ?
Comment by Alessandro Delgado (adelgado) - Wednesday, 02 November 2011, 14:16 GMT
This is still true as of now.

What would be nice to understand is what is the expected behaviour, since "Shared to other computers" isn't seem mutually exclusive with the other options.

Wouldn't it be better if the user interface had a checkbox for that?

Loading...