Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23076 - [ttf-dejavu] DejaVu and DejaVuLGC shouldn't be packaged together

Attached to Project: Arch Linux
Opened by jib (jib2) - Monday, 28 February 2011, 07:38 GMT
Last edited by Allan McRae (Allan) - Sunday, 29 April 2012, 11:06 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: ttf-dejavu installs DejaVu _and_ DejaVuLGC. But DejaVuLGC is just a subset of DejaVu with only Latin, Greek and Cyrillic scripts. They shouldn't be installed together.


Additional info:
* package version(s) 2.32-2
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Allan McRae (Allan)
Sunday, 29 April 2012, 11:06 GMT
Reason for closing:  Implemented
Additional comments about closing:  ttf-dejavu-2.33-3
Comment by Greg (dolby) - Monday, 28 February 2011, 09:21 GMT
What do you mean by 'shouldn't' ? Is it because of the license? Because noone needs support for these weird languages? Because you dont need support for these languages? Why shouldnt they be packaged together?
edit: I see, you mean those alphabets are already included in the ttf sources.
Comment by jib (jib2) - Monday, 28 February 2011, 10:04 GMT
Because support for Latin, Greek and Cyrillic is provided by both DejaVu and DejaVu-LGC.
If you need all the scripts, you need DejaVu; if you only need Latin, Greek and Cyrillic, you need DejaVu-LGC.
IMO DejaVu-LGC isn't very useful since the files are only 20 or 25% lighter than DejaVu. It could be packaged separately in Community or in AUR.

Loading...