AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://projects.archlinux.org/aurweb.git/
Tasklist

FS#23019 - character subsistution in source variable not parsed correctly

Attached to Project: AUR web interface
Opened by LouL (DrZaius) - Wednesday, 23 February 2011, 21:20 GMT
Last edited by Lukas Fleischer (lfleischer) - Thursday, 24 February 2011, 08:50 GMT
Task Type Bug Report
Category Backend
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version 1.8.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Following the naming convention for pkgname and pkgver does not allow hyphens or dashes (also uppercase for pkgname). For example when ${pkgname//ff/FF} or ${pkgver//_/-} is used to replace characters the resulting Sources URL is not displayed correctly on the AUR package page.

Example:
ffmbc - http://aur.archlinux.org/packages.php?ID=46829

Displays as: http://ffmbc.googlecode.com/files/ffmbc//ff/FF}-0.6_rc2//_/-}.tar.gz
Instead of: http://ffmbc.googlecode.com/files/FFmbc-0.6-rc2.tar.gz

Or Google site search for more examples:
site:http://aur.archlinux.org "${pkgver//_/-}"
This task depends upon

Closed by  Lukas Fleischer (lfleischer)
Thursday, 24 February 2011, 08:50 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Dupe of  FS#15043 .
Comment by Eric Belanger (Snowman) - Thursday, 24 February 2011, 00:16 GMT
That's because the AUR doesn't source the PKGBUILD for security reasons.

Loading...