Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#23014 - [util-linux] Unable to unmount FUSE filesystem after upgrade to util-linux version 2.19-3

Attached to Project: Arch Linux
Opened by Smith Dhumbumroong (zodmaner) - Wednesday, 23 February 2011, 12:09 GMT
Last edited by Ionut Biru (wonder) - Thursday, 24 February 2011, 11:14 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
After upgrade util-linux-ng package to util-linux version 2.19-3 from testing, all FUSE filesystem no longer show up on /etc/mtab after mount, making it impossible to umount them.

Downgrade util-linux package back to util-linux-ng version 2.19-4 from Core fix the problem.

Note that this bug seems to affects all FUSE file system. Both unionfs, which are written in C, and my experimental FUSE file system written in Python are both affected.

Additional info:
* package version(s)
- util-linux 2.19-3

* config and/or log files etc.
- None

Steps to reproduce:
1. Upgrade to util-linux version 2.19-3 from testing
2. Mount a FUSE file system. Notice that even though the file system is working fine, it doesn't show up on /etc/mtab
3. Attempt to unmount the file system, cannot do so because it wasn't listed on /etc/mtab
4. Downgrade to util-linux-ng, mount the FUSE file system again and note that it show up just fine in /etc/mtab
This task depends upon

Closed by  Ionut Biru (wonder)
Thursday, 24 February 2011, 11:14 GMT
Reason for closing:  Fixed
Additional comments about closing:  2.19-4. disabled the experimental flag until is marked as stable and initscripts supports it
Comment by Smith Dhumbumroong (zodmaner) - Wednesday, 23 February 2011, 13:02 GMT
I've received a suggestion from mailing list (source: http://mailman.archlinux.org/pipermail/arch-general/2011-February/018687.html) to symlink /etc/mtab to /proc/self/mounts. I've tried it and it work. Now when I mount FUSE file system it show up just fine in /etc/mtab and I can now unmount it.

Loading...