Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#22878 - [flashplugin] causes strange flash rendering leaking

Attached to Project: Arch Linux
Opened by alex (rytmenpinne) - Sunday, 13 February 2011, 12:16 GMT
Last edited by Andrea Scarpino (BaSh) - Thursday, 31 March 2011, 09:36 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan de Groot (JGC)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No


Hard to explain but after I updated the system 2 days ago I started to get strange rendering issues with flash items.. It seems that the flash item is rendered or leaks through on everything that is black on the screen. Worst thing is that it still there after I've shut down all flash media.

I've tracked it down to the libvdpau package and removed it for now.. (I find it odd that so many packages depends on it tho)

2.6.37-ARCH #1 SMP PREEMPT Sat Jan 29 19:40:04 UTC 2011 i686 AMD Athlon(tm) 64 X2 Dual Core Processor 5400+ AuthenticAMD GNU/Linux
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Thursday, 31 March 2011, 09:36 GMT
Reason for closing:  Upstream
Additional comments about closing:  we cannot do anything with flash binaries
Comment by Ionut Biru (wonder) - Sunday, 13 February 2011, 12:22 GMT
you tracked it down badly. is either a bug in flashplugin or in nvidia driver.

the hardware decoding from flashplugin is disabled by default and you have to enable from /etc/adobe/mms.cfg
Comment by alex (rytmenpinne) - Sunday, 13 February 2011, 14:20 GMT
hmm, I haven't enabled that.. but I removed libvdpau and there's no issue now.. however.. the flashplayer seems o behave slightly different.. doesn't cache videos in /tmp.. can't rightclick videos to get a menu in chrome, but in firefox I can.. and it says it's adobe's flashplayer..

Edit; enabled it in that config file and reinstalling libvdpau made the problem come back. However, some further digging I found an "enable hardware acceleration" tickbox in the flashplayer menus, unticked it and the problem is gone again.. so it seems like that config file is irrelevant(or would perhaps a reboot or logout/in be needed for it to take affect? I don't see how that would be relevant tho since hwaccel never was enabled in that config file in the first place..
Comment by Jan de Groot (JGC) - Monday, 14 February 2011, 08:28 GMT
This can't be a bug in the "updated" libvdpau, because the only difference between 0.4 and 0.4.1 are documentation updates. Maybe Adobe has added documentation reading ability to their recent flash update.
Comment by alex (rytmenpinne) - Monday, 14 February 2011, 09:46 GMT
The flashplugins was also updated I see now from pacmans log but not the nvidia drivers so it shouldn't those.. I think I may have figured it out now.. perhaps this 'bug' allways was there but adobe or someone? enabled hwacceleration in the last update? I guess they also changed the place where videos are chached... anyone knows to where? cause I often play flash files from there instead cause fullscreen flashvideo often bugs out on me on some sites.
Comment by x33a (x33a) - Tuesday, 15 February 2011, 06:32 GMT
I too am experiencing the issue.

What essentially happens is that the flash content loaded in the current tab starts displaying on other tabs too and it also displays on every gui application that we open after that, but doesn't display on a terminal emulator window nor on the desktop background, i.e., wallpaper.

Also, to get rid of it, the only option is to restart X.

I don't know if it's related to vdpau, rather i think it is caused by flashplugin.

I tried it with flashplugin, and even with today's update I enabled hardware acceleration after today's update to see if it has any effect, but the problem still persists.

I am using nvidia binary driver with nvidia 8600GT.
Comment by Jan de Groot (JGC) - Thursday, 17 February 2011, 17:51 GMT
Please report this at Adobe, we can't fix binary plugins.
Comment by Alexander Kaltsas (firewalker) - Thursday, 17 February 2011, 18:32 GMT
Maybe this version should be discarded.
Comment by dif (dif) - Thursday, 24 February 2011, 17:46 GMT
Same issue here.
Fash contents comes through other windows.
No flash saved in /tmp
Anyone knows where they might be found?
Comment by Alexander Kaltsas (firewalker) - Thursday, 24 February 2011, 19:42 GMT
The flash video are saved in the browser's cache.

Comment by Vladimir Matveev (DPX-Infinity) - Sunday, 13 March 2011, 15:26 GMT
I confirm this.
Got rid of it disabling flash hardware acceleration in /etc/adobe/mms.conf and in flash settings in rmb-menu on any flash. Switching from X virtual console to one of textual consoles and back helps.