Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#22849 - [rxvt-unicode] causing GNU screen segfault with awesomeWM

Attached to Project: Arch Linux
Opened by Daniel Campbell (xelados) - Thursday, 10 February 2011, 23:29 GMT
Last edited by Angel Velasquez (angvp) - Tuesday, 03 May 2011, 14:37 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Kieslich (tobias)
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Description: When I use awesomewm's fullscreen or maximize commands while running a screen session in urxvt, it closes the session with the message: "[screen caught signal 11.]" I tried the exact same scenario with xterm and everything worked as expected. Someone suggested transparency as a possible issue; I added transparency after this error started occurring, so I'm certain it's not that.

The keybinds I have are Win+f for fullscreen and Win+m for maximize. I don't know if these keys are used for urxvt.

Additional info:
* package version(s)
awesome 3.4.8-2
rxvt-unicode 9.10-1
screen 4.0.3-10

* config and/or log files etc. -- awesome's rc.lua -- ~/.Xdefaults -- ~/.screenrc

Steps to reproduce:

1. Run urxvt in awesome, and at least one other window. Doesn't matter what it is.
2. Run screen in urxvt.
3. Make the urxvt window fullscreen or maximized through your preferred choice.
This task depends upon

Closed by  Angel Velasquez (angvp)
Tuesday, 03 May 2011, 14:37 GMT
Reason for closing:  Not a bug
Additional comments about closing:  This seems to be hold, and the failure is produced on a non-supported application (awesomewm)
Comment by Daniel Campbell (xelados) - Thursday, 10 February 2011, 23:38 GMT
I found a possible solution while looking through Xdefaults. If you use urxvt with awesome and screen, don't include *URxvt.geometry. When I removed it from the file, it seemed to fix the problem. I'm not sure if this is the only cause, so the task will stay open until a dev or TU can confirm.
Comment by Jarek Sedlacek (J-Wreck) - Thursday, 17 February 2011, 17:27 GMT
I don't think that was the only cause. I was able to copy your .Xdefaults and .screenrc and run screen in urxvt and fullscreen with no issues using:
rxvt-unicode 9.10-1
screen 4.0.3-10
awesome 3.4.8-2
Comment by Rémy Oudompheng (remyoudompheng) - Saturday, 19 February 2011, 09:03 GMT
Please provide meaningful backtraces for segfaults. "segfault" is not a description for a problem.
Comment by Angel Velasquez (angvp) - Saturday, 19 February 2011, 13:34 GMT
AwesomeWM isn't supported anymore, so I think if a part of the equation of three things (rxvt-unicode + screen + awesome) is not supported, we can't work on this. If the problem happens on other wm we can re-open this.
Comment by Jelle van der Waa (jelly) - Wednesday, 30 March 2011, 20:11 GMT
screen is still in our repos, rxvt-unicode too, so is this an AWesomeWM rpoblem or not?
Comment by JM (fijam) - Tuesday, 03 May 2011, 09:51 GMT
Possibly a bug in Awesome which is unsupported. Candidate for closing.