Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#22781 - [xf86-video-intel] 2.14.0-1

Attached to Project: Arch Linux
Opened by Westley Martinez (anikom15) - Sunday, 06 February 2011, 03:08 GMT
Last edited by Jan de Groot (JGC) - Monday, 07 November 2011, 13:13 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:
After updating something (which I'm not entirely sure what it is), the display will randomly "fracture" (crazy artifacts) and no longer work. I can "repair" the screen by switching to console and back, but the screen doesn't respond to anything except the cursor. Thankfully I can switch back to console and reboot. This has happened atleast three times.

Additional info:
Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)
xf86-video-intel 2.14.0-1
kernel26 2.6.37-5
intel-dri 7.10-1
libxvmc 1.0.6-1
libpciaccess 0.12.0-1
libdrm 2.4.23-1
xcb-util 0.3.6-1
libxfixes 4.0.5-1
udev 165-1
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 07 November 2011, 13:13 GMT
Reason for closing:  Fixed
Additional comments about closing:  See last comments.
Comment by Maxwell Draven (Ravenman) - Sunday, 06 February 2011, 03:29 GMT
@anikom15: Look at here: https://bugs.archlinux.org/task/22604. Can you check and compares both log files (mine and yours)?
Comment by Westley Martinez (anikom15) - Sunday, 06 February 2011, 04:02 GMT
Somehow I'm unable to attach files (Epiphany bug?), so here are links to them:
ftp://innovations.selfip.net/messages.log
ftp://innovations.selfip.net/Xorg.0.log
Comment by Westley Martinez (anikom15) - Sunday, 06 February 2011, 04:06 GMT
@Ravenman: My problem seems to be unrelated.
Comment by Taras Shpot (mrshpot) - Sunday, 06 February 2011, 08:47 GMT Comment by Jan de Groot (JGC) - Sunday, 06 February 2011, 11:48 GMT
Try enabling shadowFB. I'll rebuild xf86-video-intel soon with a patch that enables that on 845G anyways. 845G chipsets are badly broken, ShadowFB is 10 times faster than native hardware accelerated operations also on this shitset.
Comment by Westley Martinez (anikom15) - Sunday, 06 February 2011, 18:37 GMT
I have turned off compositing and will report if it happens again.
Comment by Westley Martinez (anikom15) - Sunday, 06 February 2011, 21:04 GMT
After disabling compositing, the display will still randomly "fracture" but X will still respond; there are just artifacts which come and go.
Comment by Balló György (City-busz) - Sunday, 06 February 2011, 22:02 GMT
I also have 845G, and I have to added the following lines to /etc/X11/xorg.conf.d/20-intel.conf file which enables shadow buffer that solves the random GPU hangs for me (no paches required for this, however it breaks the intel dri module):
Section "Device"
Identifier "GPU"
Option "Shadow" "True"
EndSection

With earlier kernels (<2.6.37) I experienced only performance loss on GPU hangs, but after I updated kernel to version 2.6.37, my screen freezed and totally messed up, and I could only switch to console.

Some related bugs about GPU hangups on 845G:
Upstream: https://bugs.freedesktop.org/show_bug.cgi?id=26345
Ubuntu: https://bugs.launchpad.net/xserver-xorg-video-intel/+bug/541492/
openSUSE: https://bugzilla.novell.com/show_bug.cgi?id=653491
And maybe it's a duplicate of this bug: https://bugs.archlinux.org/task/17705

UPDATE: I still got GPU hangs and the screen messed up even if I enabled shadow buffer with kernel 2.6.37 and intel 2.14.0 (maybe a patch required?). It seems that it happens once a week randomly.
Comment by morgan (yossarianuk) - Thursday, 10 February 2011, 11:33 GMT
Also getting similar issues on an old (important) desktop - I really don't care about 3D on this machine I just need it to work..

VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)


dmesg:-
-----------
[drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
render error detected, EIR: 0x00000010
[drm:i915_report_and_clear_eir] *ERROR* EIR stuck: 0x00000010, masking
render error detected, EIR: 0x00000010
[drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[drm:i915_reset] *ERROR* GPU hanging too fast, declaring wedged!
[drm:i915_reset] *ERROR* Failed to reset chip.
-----------

I have added the following to xorg.conf to try to fix the issue

-----------------------------
Section "ServerFlags"
Option "AIGLX" "off"
Option "DRI" "false"
Option "NoDRI"
EndSection


Section "Module"
Disable "glx"
Disable "dri"
Disable "dri2"
EndSection

Section "Device"
Identifier "Card0"
Driver "intel"
Option "DRI" "false"
Option "SWCursor" "true" # - this doesn't seem to work
Option "NoDRI"
EndSection

Section "Extensions"
Option "Composite" "Disable"
EndSection
-----------------------------

Xorg.0.log shows:-
[ 48123.548] (EE) intel(0): failed to set cursor: Input/output error
[ 48123.549] (EE) intel(0): failed to set cursor: Input/output error
[ 48124.083] (EE) intel(0): failed to set cursor: Input/output error
[ 48124.084] (EE) intel(0): failed to set cursor: Input/output error
..... (theres 100's of these)

- it also shows that the SWcursor command did not work

[root@planetwin ~]# cat /var/log/Xorg.0.log | grep -i cursor
[ 21.620] (II) intel(0): Initializing HW Cursor
[ 21.645] (WW) intel(0): Option "SWCursor" is not used

And there dri is still enabled :-

[ 21.239] (WW) "dri" will not be loaded unless you've specified it to be loaded elsewhere.
[ 21.239] (WW) "dri2" will not be loaded unless you've specified it to be loaded elsewhere.
[ 21.239] (II) "dri" will be loaded even though the default is to disable it.
[ 21.239] (II) "dri2" will be loaded even though the default is to disable it.


The annoying thing is that this used to work fine (about 1 year ago or whenever KMS was used) every time there is a intel driver update it seems to be more unstable.. (although it used to freeze the system entirely now the 'crash' puts random lines across the screen and makes it unuseably slow.

I also have the following grub line:-

drm_kms_helper.poll=0 - makes no difference.

If I use i915.modeset=0 then I can also get basic resolutions (i.e not 1440x900).

Can anyone help make this machine work ? - it used to with old kernel ( < 2.6.33 / intel drivers.)
Comment by Jan de Groot (JGC) - Thursday, 10 February 2011, 19:28 GMT
You should read comments instead of assuming things. SWCursor != ShadowFB.
Comment by Thiago Silva (thisab) - Saturday, 12 February 2011, 12:52 GMT
I`m also having the same problem with a Eee 701. With an older kernel and xorg intel driver everything is fine.
After this dmesg output the external screen starts blinking and lots of artifacts appear.

[drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -11 (awaiting 82511 at 82429, next 82512)
[drm:i915_reset] *ERROR* Failed to reset chip.
Comment by Evaggelos Balaskas (ebal) - Monday, 14 February 2011, 21:16 GMT
I really dont understand why you people havent yet remove xf86-video-intel-2.14.0-1 from extra ?
It's obvious that xf86-video-intel-2.13.0-4-i686.pkg.tar.xz is the stable one, and 2.14.0 has problems.
Perhaps for some people works fine, but it's a fact that 2.14.0 doesnt work for a lot of people.

(EE) intel(0): Failed to submit batch buffer, expect rendering corruption or even a frozen display: No such device

grep -c EE /var/log/Xorg.0.log.old
5933
Comment by Jan de Groot (JGC) - Thursday, 17 February 2011, 15:16 GMT
Status with libdrm 2.4.23-2 from extra and xf86-video-intel 2.14.0-2 from testing?
Comment by Maxwell Draven (Ravenman) - Friday, 18 February 2011, 22:01 GMT
My case is the same like anikom15 and like morgan, I have the same messages in my errors log file and . Log files attached here: https://bugs.archlinux.org/task/22604.
Comment by Maxwell Draven (Ravenman) - Friday, 18 February 2011, 22:06 GMT
My case is the same like anikom15 and like morgan, I have the same messages in my errors log file. Log files attached here: https://bugs.archlinux.org/task/22604.
Comment by Westley Martinez (anikom15) - Thursday, 03 March 2011, 23:27 GMT
libdrm 2.4.23-2 and xf86-video-intel 2.14.0-2 doesn't fix it.
Comment by Westley Martinez (anikom15) - Friday, 04 March 2011, 02:19 GMT
Now I have a worse problem: X freezes; can't use mouse or keyboard and can't switch to ttys, but I can reboot with magic SysRq key.

Can't attach files (frustrating) for some stupid reason, here's links:
ftp://innovations.selfip.net/messages.log.new
ftp://innovations.selfip.net/Xorg.0.log.new
Comment by Balló György (City-busz) - Thursday, 10 March 2011, 02:05 GMT
Now I sent the current state of this bug to the upstream bugtracker: https://bugs.freedesktop.org/show_bug.cgi?id=26345#c124

Downgrading to kernel version 2.6.36 partially solves the problem.
If you have some more information about random hungs with 845G chip, please send them to the upstream bugtracker also.
Comment by Guillaume Brunerie (Fractal) - Sunday, 24 July 2011, 09:50 GMT
According to the upstream bug report xf86-video-intel_2.15.0 (available in [extra]) should fix the problem, is it the case?
Comment by Westley Martinez (anikom15) - Sunday, 24 July 2011, 20:55 GMT
Yes it does. Only problem now is 3D acceleration doesn't really work, though that could just be my own fault for not bothering how to setup/fix it, and it's not necessary for the uses of the computer that has the said chipset.
Comment by Balló György (City-busz) - Monday, 22 August 2011, 07:10 GMT
The reported problem had gone. (Tested with xf86-video-intel 2.15.0-2)
However the source of this bug is still exist ( FS#17705  - Hangcheck timer elapsed... GPU hung), so I propose to close this bug or mark it as a duplicate of  FS#17705 .

Loading...