Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#22705 - [xfce4-sensors-plugin] 1.0.0-3 doesn't save properties

Attached to Project: Arch Linux
Opened by indianahorst (indianahorst) - Tuesday, 01 February 2011, 19:52 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 17 May 2011, 19:27 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
xfce4-sensors-plugin 1.0.0-3 doesn't save properties, but just returns to the default "Sensors" title.

Additional info:
Package version:
xfce4-sensors-plugin 1.0.0-3 on x86_64


Steps to reproduce:
Add xfce4-sensors-plugin to xfce panel and check one (or more) sensors to display. It will be instantly on the panel, but clicking on "Close" in the "Sensors Plugin" window lets the data disappear and it remains only the title "Sensors".
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 17 May 2011, 19:27 GMT
Reason for closing:  Fixed
Comment by Asser Lähdemäki (Acce) - Monday, 14 February 2011, 05:36 GMT
  • Field changed: Percent Complete (100% → 0%)
This is not a duplicate with  FS#20399  in my case.

Since sensors applet won't save the properties _at all_, it is not able to save them until reboot or anything.

I have checked that I have read/write permission to the config file, but still nothing.
Comment by Andreas Radke (AndyRTR) - Monday, 14 February 2011, 18:57 GMT
http://bugzilla.xfce.org/show_bug.cgi?id=6734 - If that it something different please file your bug your own upstream. I don't use that plugin.
Comment by Asser Lähdemäki (Acce) - Friday, 04 March 2011, 23:08 GMT
I'm sorry if I'm asking in the wrong place, but I think this is related.

I noticed that dmesg frequently prints this when I try to save settings:
xfce4-sensors-p[4436]: segfault at 0 ip b7031a33 sp bf81d83c error 4 in libc-2.13.so[b6fbe000+145000]
xfce4-sensors-p[4873]: segfault at 0 ip b7067a33 sp bfde5d9c error 4 in libc-2.13.so (deleted)[b6ff4000+145000]
xfce4-sensors-p[5445]: segfault at 0 ip b6f489c3 sp bfadb65c error 4 in libc-2.13.so[b6ed5000+145000]
xfce4-sensors-p[5913]: segfault at 0 ip b7074a33 sp bfbcf21c error 4 in libc-2.13.so[b7001000+145000]
xfce4-sensors-p[5920]: segfault at 0 ip b6fbaa33 sp bfa95f3c error 4 in libc-2.13.so[b6f47000+145000]

Does this mean the problem is in libc rather than in xfce4-sensors-plugin?

Also similar bug seems to have existed in past: http://bugs.gentoo.org/318755
I will try to install xfce4-sensors from git and see if it will be resolved.
Comment by Asser Lähdemäki (Acce) - Saturday, 05 March 2011, 00:16 GMT
Ok, installed from git and applied patch suggested in bugs.gentoo.org,
behaviour and dmesg output still same.

Before reporting to upstream, I would like to make sure it is xfce4-sensors bug, since I'm not really sure.
I hope someone could give an opinion about it.
Comment by Andreas Radke (AndyRTR) - Thursday, 24 March 2011, 20:11 GMT
I now have something similar. The weather plugin often looses its configuration here. Maybe it's a more generic plugin issue.
Comment by Alessio Sergi (alexwizard) - Tuesday, 12 April 2011, 09:27 GMT
By applying the patch suggested in http://bugs.gentoo.org/318755, the issue no longer exists for me.
Comment by Andreas Radke (AndyRTR) - Thursday, 12 May 2011, 08:22 GMT
Please test new release 1.2.1 in extra.
Comment by Asser Lähdemäki (Acce) - Friday, 13 May 2011, 06:45 GMT
I was hopeful, but for some reason it doesn't work at all anymore.
Running "xfce4-sensors" gives the output in attached file.
Comment by Heiko Baums (cyberpatrol) - Friday, 13 May 2011, 08:02 GMT
For me it's fixed in 1.2.1. I can't reproduce Asser's issues.

But according to upstream you'd better build it with ./autogen.sh instead of ./configure as it is done in xfce4-sensors-plugin-git (http://aur.archlinux.org/packages.php?ID=31168). And I doubt that your patches (git.patch) are necessary. For me it works without them. If they are you probably should file appropriate bug reports to upstream.

See this upstream bug report:
https://bugzilla.xfce.org/show_bug.cgi?id=6734
Comment by Andreas Radke (AndyRTR) - Friday, 13 May 2011, 10:33 GMT
When it's fixed we should close this bug.

The segfault seems to be something different. Please check for an old broken config file. You should report this in a new issue if you cannot solve it. Does a git build from AUR brash the same way?
Comment by Asser Lähdemäki (Acce) - Friday, 13 May 2011, 13:18 GMT
Finding this bit of advice
http://ubuntuforums.org/showthread.php?t=175050

and following it, adding export MALLOC_CHECK_=0 to .xinitrc made it work!

I'm happy it works, but makes me wonder, why did I have to add that while you guys didn't? Well, guess the question doesn't really belong here anymore.

Loading...