Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#22700 - [noveau,xorg] GUI broken after libdrm and nouveau upgrades

Attached to Project: Arch Linux
Opened by Baeyens (berbae) - Tuesday, 01 February 2011, 16:14 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 20 April 2011, 17:13 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

With the upgraded packages :
ibdrm 2.4.23-1
libgl 7.10-1
libva 1.0.8-1
mesa 7.10-1
xf86-video-nouveau 0.0.16_git20101217-1

my GUI is unusable, the screen looks the same as the screen-shot shown in https://bbs.archlinux.org/viewtopic.php?id=112758

If I downgrade to preceding versions :
ibdrm 2.4.22-3
libgl 7.9.0.git20101207-2
libva 1.0.6-1
mesa 7.9.0.git20101207-2
xf86-video-nouveau 0.0.16_git20100819-2

everything works again as before.

lspci gives :
VGA compatible controller: nVidia Corporation C73 [GeForce 7100 / nForce 630i] (rev a2)

The Xorg.0.log files with the new packages and after the downgrade are identical apart from two lines :

[ 24091.237] (==) NOUVEAU(0): GLX sync to VBlank disabled.
This line appears with the new packages, but it is not the cause of the bug.
I enabled "sync to VBlank" and the result is the same.

14212.797] (--) NOUVEAU(0): Virtual size is 1440x900 (pitch 1472) with old packages which work
24091.566] (--) NOUVEAU(0): Virtual size is 1440x900 (pitch 0) with new packages which break the GUI

I don't know if it is relevant to the bug.

Apart from these two lines, everything is identical.
But the GUI is still unusable with the new packages.

It can be caused by upstream bugs.
But it is nevertheless an Archlinux upgrade problem which results in an unusable machine after 'pacman -Syu'.
I read in the Mesa 7.10 Release Notes / January 7, 2011 :
Mesa 7.10 is a new development release. People who are concerned with stability and reliability should stick with a previous release or wait for Mesa 7.10.1.

Maybe it is the source of the problem.
What do you suggest me to do now ?
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 20 April 2011, 17:13 GMT
Reason for closing:  Fixed
Additional comments about closing:  no reply. seems to be fixed.
Comment by Andreas Radke (AndyRTR) - Tuesday, 01 February 2011, 19:26 GMT
Please ask upstream devs in their #nouveau irc channel (or mailing list) if there's an upstream bug (that may be meanwhile fixed in nouveau or mesa git). To me it doesn't seem to be a packaging bug because it works for many people.
Comment by Simon (lorentz) - Tuesday, 01 February 2011, 19:47 GMT
I don't think it's an upstream bug, I've been having this problem for already several months with all the 3D-accelerated apps, before it got systemwide yesterday (everything 2D was working fine).
Comment by Ionut Biru (wonder) - Tuesday, 01 February 2011, 20:01 GMT
@Simon i'm sorry but this happens when you don't report bugs to the right people(upstream)
Comment by Simon (lorentz) - Tuesday, 01 February 2011, 20:08 GMT
Yeah... I know, but it kind of wasn't a big deal (I don't play games), so I hadn't taken the time to report it. I'm also sorry.
Comment by Xavier (shining) - Tuesday, 01 February 2011, 22:48 GMT
When does this happen ? Directly after X is started, or after some usage ? When doing a fresh boot, console is fine though ?

Please make sure mesa is not used with pacman -R nouveau-dri and check you still have the problem.

And first thing to *always* provide is a full dmesg from boot until corruption happens. A full Xorg.0.log at the same time can also help but less.
Comment by Baeyens (berbae) - Tuesday, 01 February 2011, 23:21 GMT
The problem occurs after a fresh boot and the console is fine (KMS works normally).
Everything is normal in dmesg and Xorg.0.log files (only the two lines mentioned above are different with the new packages).
X and the WM is started (ps -ef gives normal processes output), only the display on the screen is bad and unusable.

I don't use nouveau-dri. Do you mean that mesa is used only if nouveau-dri is installed ?
Comment by Xavier (shining) - Tuesday, 01 February 2011, 23:28 GMT
Either provide the logs or don't even report a bug.
But thanks for the other info.
If nouveau-dri is not installed, mesa can be used but only in software rendering, which does not interact with nouveau and so does not mess up anything (but is almost always too slow to be usable).
Comment by sacarde (sacarde) - Wednesday, 02 February 2011, 07:54 GMT
some problem here

[GeForce 6150SE nForce 430]


if I exec: X -configure
I have:
...
(EE) [drm] No DRICreatePCIBusID symbol
Comment by Leonid Isaev (lisaev) - Wednesday, 02 February 2011, 17:38 GMT
FWIW, I am with AndyRTR here. Nouveau/nouveau-dri/kms works on my NV10 card, so packaging is OK.

@sacarde: Your report seems to point to a NV40 -- specific bug, which has to be reported for freedesktop's bugzilla.
Comment by Guillaume C (TortuXm) - Wednesday, 02 February 2011, 21:28 GMT
Hello, I am experiencing exactly the same behaviour.

Like Simon, I always had garbage when using 3D accelerated apps (but I didn't report it since I am using nouveau-dri and the wiki advised against filing bugs for 3D in nouveau). Since the update, this happens everywhere in X, except the mouse cursor.

Downgrading only xf86-video-nouveau works for me.

I can provide any information tomorrow if needed (I don't have access to that computer at the moment)
Comment by Xavier (shining) - Wednesday, 02 February 2011, 22:40 GMT
It sucks that no one filed a bug yet at bugzilla, but there is a thread on the ML now :
http://lists.freedesktop.org/archives/nouveau/2011-February/007463.html
Comment by Baeyens (berbae) - Friday, 04 February 2011, 14:16 GMT
A bug report for the nouveau driver development team is now opened :
https://bugs.freedesktop.org//show_bug.cgi?id=33887

We now only have to hope it will be fix soon.
Comment by Andreas Radke (AndyRTR) - Friday, 04 February 2011, 14:37 GMT
CC'ed to it.
Comment by sacarde (sacarde) - Thursday, 17 February 2011, 09:35 GMT
[2011-02-13 08:52] upgraded nouveau-dri (7.10-1 -> 7.10.0.git20110206-2)


new upgrade nouveau dont solve
Comment by Xavier (shining) - Thursday, 17 February 2011, 09:46 GMT
Who ever said the problem was in mesa and got fixed there ?

What you need to apply is a kernel patch :
http://cgit.freedesktop.org/nouveau/linux-2.6/commit/?id=aaa3d08c357dcfbe13ec23786c294759183a4d8d
Comment by Andreas Radke (AndyRTR) - Wednesday, 30 March 2011, 20:25 GMT
This patch should be included in kernel 2.6.38.x series that is in testing now for some time. Is it fixed now?

Loading...