Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#22693 - libreoffice slow startup when network is enabled

Attached to Project: Arch Linux
Opened by Chuck (foxcm2000) - Tuesday, 01 February 2011, 03:41 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 01 February 2011, 05:40 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No



Libreoffice (and before it OpenOffice begin after version 3.2) are very slow to start on my PC. I found a similar report of slow startup times for Ubuntu where the user noted that LibreOffice started much more quickly when networking was disabled. I disabled eth0 (ifconfig eth0 down) LibreOffice starts MUCH faster.
Note: I actually have 3 active ethernet interfaces on my PC, but I *only* have to disable eth0 (the primary interface for Internet packets) to get the speedup.
So: Why does LibreOffice need to access the network when starting up? How can I turn this off? I have a relatively fast internet connection and other programs that access the network open quite quickly. Only LibreOffice is slow. The program gives no error diagnostics or logs that I can find explaining what is happening.

Additional info:
* package version(s):
Any version of Libre Office 3.3

* config and/or log files etc.

Steps to reproduce:
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 01 February 2011, 05:40 GMT
Reason for closing:  Not a bug
Additional comments about closing:  you want support for your setup. this is not an issue for our bugtracker.
Comment by Chuck (foxcm2000) - Tuesday, 01 February 2011, 03:57 GMT
Follow up:

I now know the cause of the long delay, but I still need a solution. The cause is that I have defined a "wins" server in my nsswitch.conf file. The "wins" server in question is really a SAMBA server that I only use intermittently via a VPN. I ran tcpdump and found that libreoffice was sending UDP packets on port 137 trying to get some information from the WINS server. When the VPN is down (it usually is) the packets have to timeout before libreoffice finishes initializing.

So: How can I get libreoffice to just startup and not try to ping WINS servers? To put this in perspective, I can start Microsoft Word 2007 via Crossover Office without using any autoloading tricks much faster than Libre Office writer starts by default!