Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#22656 - [prelink] glibc 2.13 + prelink == hosed system

Attached to Project: Community Packages
Opened by John Schoenick (Nephyrin) - Saturday, 29 January 2011, 11:32 GMT
Last edited by Allan McRae (Allan) - Friday, 18 February 2011, 23:02 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Allan McRae (Allan)
Lukas Fleischer (lfleischer)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No


On 64-bit, having glibc 2.13 installed with prelink 20100106 will cause the daily prelink cron job to annihilate your system. Every dynamic executable that pulls in libc to immediately segfault.

I have not tested this on 32-bit.

This is almost certainly a bug in prelink, but I feel it would be prudent to have glibc conflict with the affected versions of prelink to prevent more poor SOBs like me from spending 40 minutes swearing at a live CD trying to figure out why every executable hates you.

Fellow victims:

Steps to reproduce:
* Install glibc-2.13
* Install prelink-20100106 from community
* Run prelink -aR or let the cronjob do its thing
* Observe hosed system
This task depends upon

Closed by  Allan McRae (Allan)
Friday, 18 February 2011, 23:02 GMT
Reason for closing:  Fixed
Additional comments about closing:  glibc-2.13-4 in [testing], will move to [core] soon.
Comment by Allan McRae (Allan) - Saturday, 29 January 2011, 11:39 GMT
  • Field changed: Category (Upstream Bugs → Packages)
  • Field changed: Architecture (All → All)
  • Task assigned to Lukas Fleischer (lfleischer)
Assigning as a prelink bug... my glibc package is perfect! :P
Comment by Andrej Podzimek (andrej) - Sunday, 30 January 2011, 12:04 GMT
Exactly the same proble here. The system simply became FUBAR in an instant. I had to boot from the rescue CD, mount my partitions, connect to the network and do something like this:

pacman -r /mnt -Sy `pacman -r /mnt -Q | cut -d' ' -f1 | tr '\n' ' '`

I have never seen commands like sync to segfault ... up to now. Sounds like a piece of adventure. :-)
Comment by Ionut Biru (wonder) - Sunday, 30 January 2011, 12:11 GMT
from what i see in fedora history, they are using newer snapshots that are not yet published in old location.

better email the upstream maintainer and see what you can do about this.
Comment by Lukas Fleischer (lfleischer) - Monday, 31 January 2011, 08:34 GMT
Sent a mail to the prelink maintainer. Waiting for response.
Comment by Ryan Hill (dirtyepic) - Monday, 07 February 2011, 22:05 GMT
Any response? We just hit this in Gentoo.
Comment by Lukas Fleischer (lfleischer) - Tuesday, 08 February 2011, 08:27 GMT
  • Field changed: Status (Assigned → Waiting on Response)
  • Field changed: Category (Packages → Upstream Bugs)
dirtyepic: Unfortunately not. I sent Jakub a mail on January, 31st and another one four days ago. Not a single response yet. I'll try my best...
Comment by Ryan Hill (dirtyepic) - Wednesday, 09 February 2011, 00:08 GMT
Thanks. If it saves you some time, we're running prelink-20101123 which should be the latest Fedora has.
Comment by Lukas Fleischer (lfleischer) - Wednesday, 09 February 2011, 09:44 GMT
dirtyepic: So that bug occurs with the latest snapshots as well?
Comment by Ryan Hill (dirtyepic) - Sunday, 13 February 2011, 11:37 GMT
Comment by Lukas Fleischer (lfleischer) - Sunday, 13 February 2011, 13:15 GMT
Well, this is a quite critical bug but upstream seems to be completely dead. In my last mail, I just asked for short reply to find out if my mails are read at all - no response. Also, I doubt that we're able to debug this on our own quickly. I'm probably gonna drop this and move it to the AUR soon. Let's give Jakub a few more days...
Comment by Nikos Chantziaras (realnc) - Monday, 14 February 2011, 04:58 GMT
Someone bisected the glibc commit that broke prelink:
Comment by Allan McRae (Allan) - Monday, 14 February 2011, 05:58 GMT Comment by Allan McRae (Allan) - Monday, 14 February 2011, 06:46 GMT
And the fix which is only found on the fedora glibc branch (and hence fedora not being affected...):;a=commit;h=25b3aada

Waiting for upstream comment on why this is not in the main glibc source, but will likely do a glibc rebuild with it soon anyway...
Comment by Ionut Biru (wonder) - Monday, 14 February 2011, 15:19 GMT
@Allan typically redhat. They compensate bugs in software in packaging.
Comment by Ryan Hill (dirtyepic) - Wednesday, 16 February 2011, 04:03 GMT
We did a revision bump with this patch a couple days ago and it's working fine. If you're doing a bump you may also want to look at
Comment by Allan McRae (Allan) - Wednesday, 16 February 2011, 04:29 GMT
That does not affect the main Arch toolchain as it is not multiarch.
Comment by Allan McRae (Allan) - Friday, 18 February 2011, 04:48 GMT
glibc-2.13-4 is now in [testing]