Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#22646 - [python2-qscintilla] [python-qscintilla] needs a rebuild about new pyqt

Attached to Project: Arch Linux
Opened by Julien (ganymede) - Saturday, 29 January 2011, 00:35 GMT
Last edited by Andrea Scarpino (BaSh) - Saturday, 29 January 2011, 14:28 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: eric4 crashes at start with the following error message (in a console) :
"""
using the error reporting dialog or via email to <eric4-bugs@eric-ide.python-projects.org>.
A log has been written to "/home/julien/.eric4/eric4_error.log".

Error information:
--------------------------------------------------------------------------------
2011-01-29, 01:27:34
--------------------------------------------------------------------------------
<type 'exceptions.TypeError'>:
QsciLexer.readSettings(QSettings, str="/Scintilla"): argument 1 has unexpected type 'QSettings'
--------------------------------------------------------------------------------
File "/usr/lib/python2.7/site-packages/eric4/eric4.py", line 282, in <module>
main()
File "/usr/lib/python2.7/site-packages/eric4/eric4.py", line 279, in main
raise err

--------------------------------------------------------------------------------
Version Numbers:
Python 2.7.1
KDE 4.6.0
PyKDE 4.0.2
Qt 4.7.1
PyQt4 4.8.3
sip 4.12.1
QScintilla 2.4.6
eric4 4.4.9 (r3848)

Platform: linux2
2.7.1 (r271:86832, Jan 6 2011, 11:45:30)
[GCC 4.5.2]
--------------------------------------------------------------------------------
Distribution Info:
/etc/arch-release
"""

Additional info:
* package version(s) : latest (4.4.9)


Steps to reproduce: just start eric.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Saturday, 29 January 2011, 14:28 GMT
Reason for closing:  Fixed
Additional comments about closing:  python-qscintilla 2.4.6-6
python2-qscintilla 2.4.6-5
Comment by Lazarus (Lazarus) - Saturday, 29 January 2011, 05:20 GMT
I got the same error yesterday with eric5. I was using eric5 normally, but then it suddenly crashed. Since then this errors happens whenever I try to start eric5. Sent a bug report to the below email address but haven't gotten a reply yet.

An unhandled exception occurred. Please report the problem
using the error reporting dialog or via email to <eric5-bugs@eric-ide.python-projects.org>.
A log has been written to "/home/ark/.eric5/eric5_error.log".

Error information:
--------------------------------------------------------------------------------
2011-01-29, 14:14:18
--------------------------------------------------------------------------------
<class 'TypeError'>:
QsciLexer.readSettings(QSettings, str="/Scintilla"): argument 1 has unexpected type 'QSettings'
--------------------------------------------------------------------------------
File "/usr/lib/python3.1/site-packages/eric5/eric5.py", line 263, in <module>
main()
File "/usr/lib/python3.1/site-packages/eric5/eric5.py", line 260, in main
raise err
File "/usr/lib/python3.1/site-packages/eric5/eric5.py", line 244, in main
mainWindow = UserInterface(app, loc, splash, pluginFile, noopen, restartArgs)
File "/usr/lib/python3.1/site-packages/eric5/UI/UserInterface.py", line 249, in __init__
self.__createLayout(debugServer)
File "/usr/lib/python3.1/site-packages/eric5/UI/UserInterface.py", line 711, in __createLayout
self.__createToolboxesLayout(debugServer)
File "/usr/lib/python3.1/site-packages/eric5/UI/UserInterface.py", line 930, in __createToolboxesLayout
self.terminal = Terminal(self.viewmanager)
File "/usr/lib/python3.1/site-packages/eric5/QScintilla/Terminal.py", line 121, in __init__
self.__bindLexer()
File "/usr/lib/python3.1/site-packages/eric5/QScintilla/Terminal.py", line 261, in __bindLexer
self.lexer_.readSettings(Preferences.Prefs.settings, "Scintilla")

--------------------------------------------------------------------------------
Version Numbers:
Python 3.1.3
Qt 4.7.1
PyQt4 4.8.3
sip 4.12.1
QScintilla 2.4.6
eric5 5.0.5 (rev 4daa1d31f4ba)

Platform: linux2
3.1.3 (r313:86834, Dec 1 2010, 12:16:07)
[GCC 4.5.1 20101125 (prerelease)]
--------------------------------------------------------------------------------
Distribution Info:
/etc/arch-release
Comment by Lazarus (Lazarus) - Saturday, 29 January 2011, 05:39 GMT
Considering the timing of these bug reports I checked the time stamps of my pacman updates and have found that an update of the following packages exactly coincided with the timing of the initial crash I experienced.

drwxr-xr-x 2 root root 4096 Jan 28 14:51 python2-qt-4.8.3-1
drwxr-xr-x 2 root root 4096 Jan 28 14:51 python2-sip-4.12.1-1
[...]
drwxr-xr-x 2 root root 4096 Jan 28 14:51 python-qt-4.8.3-1
drwxr-xr-x 2 root root 4096 Jan 28 14:51 python-sip-4.12.1-1

I'm therefore now 95% sure this bug is python(2)-qt and/or python(2)-sip related.
Comment by Lazarus (Lazarus) - Saturday, 29 January 2011, 05:50 GMT
Triple posting. This may have something to do with it: http://www.riverbankcomputing.co.uk/news/pyqt-483

"
PyQt v4.8.3 has been released. This includes enhanced support for working with QVariant objects and Python v3.

* Added the QPyNullVariant class to the QVariant v2 API to allow null QVariants to be implemented.
* Added the optional type keyword argument to QSettings.value() to allow the type of the returned value to be specified.
* QDeclarativeItem will now act as a transparent proxy from any QML signals and JavaScript functions.
* Any QObject invokable methods can now be called transparently even if they haven't been explicitly wrapped.
* QWizardPage.registerField() can now take an unbound or bound signal as its changedSignal argument.
* Converted the Reference Guide to Sphinx.
"

That second bullet point?
Comment by Julien (ganymede) - Saturday, 29 January 2011, 11:33 GMT
Detlev Offenbach (eric's developper) pointed out the solution on eric's mailing list :
"""
These kind of issues usually arise from forgetting to rebuild QScintilla
Python bindings after a PyQt upgrade.
"""
This problem can be fixed by rebuilding the python(2)-qscintilla package.
At least it worked for me.
Comment by Andrea Scarpino (BaSh) - Saturday, 29 January 2011, 12:30 GMT
please try with python-qscintilla 2.4.6-6 and python2-qscintilla 2.4.6-5 (uploaded now)
Comment by Julien (ganymede) - Saturday, 29 January 2011, 14:27 GMT
python2-qscintilla 2.4.6-5 fixes the problem for me. Thank you.

Loading...