Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#22587 - [feh] Crashes when viewing images.

Attached to Project: Arch Linux
Opened by Xyne (Xyne) - Monday, 24 January 2011, 11:13 GMT
Last edited by Gaetan Bisson (vesath) - Wednesday, 26 January 2011, 11:11 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

The latest version of feh (1.11-1) crashes when viewing images if any key is pressed or when trying to access the right-click menu.

feh WARNING: the config is now read from .config/feh/themes, please update your path!
giblib warning: couldn't load font yudit/10, attempting to fall back to fixed.
giblib warning: failed to even load fixed! Attempting to find any font.
feh ERROR: couldn't load menu font yudit/10, did you make install?
Are you specifying a nonexistant font?
Did you tell feh where to find it with --fontpath?


https://bbs.archlinux.org/viewtopic.php?id=112257
This task depends upon

Closed by  Gaetan Bisson (vesath)
Wednesday, 26 January 2011, 11:11 GMT
Reason for closing:  Fixed
Additional comments about closing:  feh-1.11-3 in [extra]
Comment by Jan de Groot (JGC) - Monday, 24 January 2011, 12:00 GMT
make -> make PREFIX=/usr in the build() function should fix this.
Comment by Gaetan Bisson (vesath) - Monday, 24 January 2011, 12:22 GMT
Right. I'm taking care of that.
Comment by Gaetan Bisson (vesath) - Wednesday, 26 January 2011, 07:36 GMT
Xyne is still having issues with 1.11-2.
Comment by Gaetan Bisson (vesath) - Wednesday, 26 January 2011, 08:52 GMT
So I just found a computer which seems to exhibit the same symptoms as Xyne's:
Even if I download the feh-1.11 source tarball and just compile with a simple make, the binary I obtain does detect key events.
There is no error message...
Comment by Xyne (Xyne) - Wednesday, 26 January 2011, 08:53 GMT
I think my issue is unrelated to this bug.

It simply doesn't recognize keyboard input. I can access the menu by right-clicking, and left clicking changes to the next image, but pressing keys, including esc, does nothing. There is no console output and it does not crash as it in 1.11-1.

I tried using the example key configuration file (copied to $XDG_CONFIG_HOME/feh/key, i.e. ~/.config/feh/key) but that did nothing.
I also tried removing the configuration file.
Rebuilding the package using the 1.11-2 PKGBUILD produces no errors but the built package still does not recognize keyboard input.

I am on a fully updated x86_64 system.
Comment by Gaetan Bisson (vesath) - Wednesday, 26 January 2011, 10:18 GMT
Alright. I came up with a quick and dirty fix.
The issue here was that keystates always have the bit 2^4 set to 1 (I have no clue why); the quick fix simply ignores this bit just like feh does with the bit 2^0 (corresponding to Shift); so rather than xoring with 0x1 we xor with 0x11.
Xyne, it'd be great if you could let me know if that patch solves your issues as well.
Comment by Gaetan Bisson (vesath) - Wednesday, 26 January 2011, 11:00 GMT
Oh, I got it: the 2^4 bit corresponds to Mod2Mask which is the NumLock key... Turn it off and feh will work normally even without the patch.
Comment by Gaetan Bisson (vesath) - Wednesday, 26 January 2011, 11:06 GMT

Loading...