Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#22586 - [upower] Monitor turns black every 30 seconds

Attached to Project: Arch Linux
Opened by AKL (AKL) - Monday, 24 January 2011, 09:12 GMT
Last edited by Andrea Scarpino (BaSh) - Saturday, 07 May 2011, 00:44 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:

When a monitor is connected with an VGA cable and an adapter at the DVI port of an ATI 1950XT, the screen turns black every 30 seconds for about a second.
When starting the screen settings app of XFCE, the screen turns also black for a second. Making changes in this app like changing resolution or frequency turns the screen black permanently.
When connecting the monitor directly with DVI all problems are solved.

Additional info:
* package version(s)
* config and/or log files etc.

Before this update everything worked fine:

[2011-01-21 17:02] starting full system upgrade
[2011-01-21 17:02] removed sip (4.12-3)
[2011-01-21 17:02] removed pyqt (4.8.2-2)
[2011-01-21 17:02] upgraded dmidecode (2.10-1 -> 2.11-1)
[2011-01-21 17:02] upgraded ffmpeg (26387-1 -> 20110121-1)
[2011-01-21 17:02] upgraded pm-utils (1.4.1-1 -> 1.4.1-2)
[2011-01-21 17:02] upgraded python2-sip (4.12-2 -> 4.12-4)
[2011-01-21 17:02] upgraded python2-qt (4.8.2-3 -> 4.8.2-4)
[2011-01-21 17:02] upgraded upower (0.9.7-2 -> 0.9.8-2)
[2011-01-21 17:02] upgraded xfce4-diskperf-plugin (2.1.0-5 -> 2.3.0-1)
[2011-01-21 17:03] Running 'pacman -Scc'

Steps to reproduce:

See above.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Saturday, 07 May 2011, 00:44 GMT
Reason for closing:  Fixed
Additional comments about closing:  upower 0.9.10-1
Comment by Ionut Biru (wonder) - Monday, 24 January 2011, 09:52 GMT
try downgrading upower and if is working please report this bug upstream.

https://bugs.freedesktop.org/enter_bug.cgi?product=upower
Comment by Ionut Biru (wonder) - Monday, 24 January 2011, 14:56 GMT
so here is what i want from you guys.

1) report upstream
2) try to git disect and find the commit. http://cgit.freedesktop.org/upower/log/
3) ask upstream on their mailing list for proper debugging on this [*]


[*] http://lists.freedesktop.org/mailman/listinfo/devkit-devel

Comment by Tobias (AliWam) - Monday, 24 January 2011, 23:02 GMT Comment by Jan de Groot (JGC) - Tuesday, 25 January 2011, 10:35 GMT
Does your screen turn black also when you execute this:

cd /sys/class/drm
for i in *; do
cat $i/status
done

If that causes your screen to turn black, then it's a bug in the ATI kernel driver that blanks your screen when reading those status files from sysfs. It would be nice if you could give the output for both VGA and DVI like you said in your initial bugreport.
Comment by Tobias (AliWam) - Tuesday, 25 January 2011, 14:39 GMT
Hey,

I executed your script and the screen turned black; connected to the VGA port. I'm not able to test the DVI/HDMI port.
I'm using a Intel GMA HD internal graphic card in my laptop.

I also furthermore noticed, when I execute xrandr (with and without any options) the screen turns black twice. First one directly after I used the command, second one 10 seconds later.
Comment by Paulo Santos (Sayo) - Tuesday, 25 January 2011, 15:30 GMT
Happening to me as well.

Tried on a Nvidia graphics card and on a Intel+Nvidia (Optimus with the Nvidia disabled - so it's on a Intel GMA something, I guess) with a CRT connected to the VGA port. Every X secconds the screen goes black for 1 seccond or so, like the reported issue, although I can change resolutions on the Gnome monitor app. This happens on both X and tty's, even during boot.

Downgrading to 0.9.7-2 fixed the issue.

Reporting upstream.
Comment by Jan de Groot (JGC) - Tuesday, 25 January 2011, 23:15 GMT
Looks like a bug in the i915 kernel driver. On some models reading the status file from sysfs seems to cause a re-detected screen. As xf86-video-intel has been compiled with udev support, this means that the driver will respond on uevents generated by that fact.
Comment by Ionut Biru (wonder) - Thursday, 27 January 2011, 11:38 GMT
have you guys tried to update to kernel 2.6.37 from testing and see if is fixed?
Comment by Carl Mueller (cmlr) - Thursday, 27 January 2011, 14:19 GMT
Upgrading to kernel 2.6.37 solved the problem for me!
Comment by Daniel (Doehni) - Friday, 28 January 2011, 01:42 GMT
I have the same issue with an ATI Mobility 7500 card (open radeon driver):
VGA compatible controller: ATI Technologies Inc Radeon IGP 330M/340M/350M

Upgrading to kernel 2.6.37 did not help me! Only killing upowerd does...
Comment by Peter Frase (pefrase) - Sunday, 06 March 2011, 14:02 GMT
I have the same problem. ATI Radeon HD 4670, with two monitors connected with VGA cables and DVI adapters. Kernel 2.6.37. One of my monitors, but not the other, was flashing at regular intervals when using a single desktop stretched across both monitors in KDE. The issue went away when I downgraded upower to 0.9.7-2.
Comment by JM (fijam) - Monday, 02 May 2011, 20:11 GMT
Does the problem persist with upower 0.9.9 and kernel 2.6.38?
Comment by Peter Frase (pefrase) - Friday, 06 May 2011, 20:47 GMT
I upgraded to upower 0.9.10 and the problem seems to have gone away.

Loading...