Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#22572 - [gourmet] missing dependency: python2-poppler

Attached to Project: Community Packages
Opened by Balló György (City-busz) - Sunday, 23 January 2011, 20:56 GMT
Last edited by Ray Rashif (schivmeister) - Friday, 28 January 2011, 19:33 GMT
Task Type Feature Request
Category Packages
Status Closed
Assigned To Ray Rashif (schivmeister)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

python2-poppler is a missing dependency. If it's not exist, I get the following error:
"ImportError: No module named poppler"
I attached a PKGBUILD for python2-poppler.

And now, gnome-python-extras package is splitted by modules, so it can be replaced by the appropriate modules. The dependency array could be the following:
depends=('python2-libgnome' 'python2-gtkspell' 'metakit' 'python-imaging' 'python2-poppler' 'python-reportlab' 'python2-sqlalchemy')
   PKGBUILD (0.7 KiB)
This task depends upon

Closed by  Ray Rashif (schivmeister)
Friday, 28 January 2011, 19:33 GMT
Reason for closing:  Implemented
Comment by Ray Rashif (schivmeister) - Monday, 24 January 2011, 10:12 GMT
Thanks..update will be rolled once I verify those deps. Hang on tight!
Comment by Ray Rashif (schivmeister) - Thursday, 27 January 2011, 16:07 GMT
  • Field changed: Task Type (Bug Report → Feature Request)
Not a bug. Without poppler bindings no core functionality is lost.
Comment by Balló György (City-busz) - Friday, 28 January 2011, 02:51 GMT
Ok, but if you think that, then you should move 'python-reportlab' also to optdepends, because gourmet's 'pdf_plugin' requires both of them, and it shows an error when you try to print a recipe if missing one of them. I think that printing support is a core feature, so please keep both of them in depends.

And it seems that libgnomeprintui is not required for printing support, you could remove them from optdepends.
Comment by Ray Rashif (schivmeister) - Friday, 28 January 2011, 15:56 GMT
python-reportlab does not need to be moved to optdepends. As per upstream [1] pyrtf and python-poppler are "extra" requirements. This way you can only be missing the rtf and poppler bindings. Just install them to complete the feature set. I have also kept gnome-python-extras as-is since upstream recommends that.

[1] http://sourceforge.net/apps/mediawiki/grecipe-manager/index.php?title=Linux_Installation
Comment by Balló György (City-busz) - Friday, 28 January 2011, 16:27 GMT
I don't think that. Run a python dependency finder (e.g. snakefood) on gourmet, and you will see that both reportlab and pypoppler are only used in pdf_plugin. The reportlab not brings any functionality without pypoppler, because both of them required by pdf_plugin.

And gnome-python-extras brings many unnecessarily dependencies, it should be avoided. Gourmet uses the python2-gtkspell module only for it's spell checking plugin; all other modules are unneeded.

At last, please see the dependences of Ubuntu's gourmet package: https://launchpad.net/ubuntu/natty/i386/gourmet/0.15.7-1#depends
Comment by Ray Rashif (schivmeister) - Friday, 28 January 2011, 16:52 GMT
You convinced me to go check this out and you're right. A grep reveals only pdf_exporter.py and print_plugin.py as the matches. Very well, I will add these to depends since I don't think anyone will complain about the weight of python-poppler.
Comment by Balló György (City-busz) - Friday, 28 January 2011, 17:33 GMT
Thanks. :) Anyway, gnome-python-extras is the heaviest dependency; if you replace them, Gourmet will be much lighter.

Loading...