Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#22552 - [python] missing link to libpython3.1.so in /usr/lib/python3.1/config

Attached to Project: Arch Linux
Opened by Sébastien Martinez (Garrik) - Saturday, 22 January 2011, 17:56 GMT
Last edited by Allan McRae (Allan) - Sunday, 30 January 2011, 00:11 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Allan McRae (Allan)
Stéphane Gaudreault (stephane)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: symbolic link from /usr/lib/lipython3.1.so to /usr/lib/python3.1/config/libpython3.1.so does not exist
(the link exists for python2.7)

Package: extra/python 3.1.3-1 (found in x86_64, I don't know if the i686 arch is concerned)

Steps to reproduce:
ls /usr/lib/python3.1/config
This task depends upon

Closed by  Allan McRae (Allan)
Sunday, 30 January 2011, 00:11 GMT
Reason for closing:  Fixed
Additional comments about closing:  python-3.1.3-2
Comment by Sébastien Martinez (Garrik) - Saturday, 22 January 2011, 18:02 GMT
Hum, fail on the bug name, forgot the "link" between "libpython3.1.so" and "not"
Comment by Allan McRae (Allan) - Sunday, 23 January 2011, 00:54 GMT
Why does this need to be there?
Comment by Stéphane Gaudreault (stephane) - Sunday, 23 January 2011, 02:35 GMT
Debian has such link in a libpython3.1 pkg
cf http://packages.debian.org/sid/ia64/libpython3.1/filelist
Comment by Allan McRae (Allan) - Sunday, 23 January 2011, 02:40 GMT
It seems we manually create that link in our python2 package. Still, I would like to know what actually needs it...
Comment by Sébastien Martinez (Garrik) - Sunday, 23 January 2011, 06:25 GMT
By default, for using python librairies with C, ld looks for libpython3.1.so in /usr/lib/python3.1/config while given -lpython argument
This link not beeing here caused me trouble while working on pips (http://pips4u.org/) when I was making the pips autoconf scripts python3 compatible. (I was using the autotools http://www.cri.ensmp.fr/pips/auto_pips.htdoc/).
Comment by Allan McRae (Allan) - Sunday, 23 January 2011, 06:41 GMT
By default, ld know nothing about /usr/lib/python3.1/config, and the python3 pkg-config file clearly looks in /usr/lib for the library.
Comment by Sébastien Martinez (Garrik) - Sunday, 23 January 2011, 07:05 GMT
Ok, I guess I needed it just for that particuliar purpose then.
I thought it was important since the link is made with python2
Comment by Jan de Groot (JGC) - Wednesday, 26 January 2011, 14:06 GMT
I was the one that requested or even added that symlink to the python2 package long time ago. As far as I can remember, I had some packages that would look in the config directory, where only the .a file is found. Those applications will link to libpython static, which violates packaging standards (bugs in libpython are transfered to all packages that link static to it). Adding the symlink makes those packages compile with shared libpython.
Comment by Allan McRae (Allan) - Friday, 28 January 2011, 02:57 GMT
OK, that is the reason I was looking for.

@Stéphane: do you want to do the rebuild?
Comment by Stéphane Gaudreault (stephane) - Friday, 28 January 2011, 03:15 GMT
sure :)
Comment by Stéphane Gaudreault (stephane) - Friday, 28 January 2011, 20:13 GMT
python-3.1.3-2 is in my staging.

Loading...