Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#22518 - [perl] h2ph.t produces warnings on gcc 4.5.0

Attached to Project: Arch Linux
Opened by raflik (raflik) - Thursday, 20 January 2011, 02:01 GMT
Last edited by Angel Velasquez (angvp) - Monday, 24 January 2011, 20:59 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Kevin Piche (kpiche)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Known bug which was already fixed:

http://rt.perl.org/rt3//Public/Bug/Display.html?id=75182

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Angel Velasquez (angvp)
Monday, 24 January 2011, 20:59 GMT
Reason for closing:  Implemented
Additional comments about closing:  Patch applied, on perl-5.12-2 in [testing] right now
Comment by Angel Velasquez (angvp) - Thursday, 20 January 2011, 19:48 GMT
I think this bug affect perl 5.12.1 and it's fixed on 5.12.2 or am I wrong?
Comment by Thomas Dziedzic (tomd123) - Friday, 21 January 2011, 21:59 GMT
arch is already using 5.12.2 http://www.archlinux.org/packages/core/i686/perl/

This bug has been fixed and the commit was made *over* 8 months ago in 5.13.1 which came 4 months before 5.12.2
Comment by Thomas Dziedzic (tomd123) - Monday, 24 January 2011, 20:03 GMT
I just applied the patch to 5.12.2. I don't know if this patch was ever meant to be applied to 5.12 if it is in 5.13 but not 5.12 upstream. Any suggestions?

Loading...