Release Engineering

Tasklist

FS#22429 - aif does not show complete package list during pacman package installation

Attached to Project: Release Engineering
Opened by Thomas Dziedzic (tomd123) - Friday, 14 January 2011, 17:44 GMT
Last edited by Dieter Plaetinck (Dieter_be) - Wednesday, 19 January 2011, 12:12 GMT
Task Type Bug Report
Category AIF
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 2010.05
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When selecting the install procedure, it lists the targets to install, but it doesn't wrap the list around to the next line, instead it just stays on the same line, effectively truncating the list.

Link to report from the report issues script: http://sprunge.us/gNGY
This task depends upon

Closed by  Dieter Plaetinck (Dieter_be)
Wednesday, 19 January 2011, 12:12 GMT
Reason for closing:  Not a bug
Additional comments about closing:  package list is visible in multiple other places, such as the interface where you choose packages to install
Comment by Dieter Plaetinck (Dieter_be) - Sunday, 16 January 2011, 20:06 GMT
install procedure?
targets to install?
elaborate.
Comment by Thomas Dziedzic (tomd123) - Sunday, 16 January 2011, 20:08 GMT
The list of packages (targets) it shows when you initiate the install procedure.
Comment by Dieter Plaetinck (Dieter_be) - Sunday, 16 January 2011, 20:21 GMT
when you initiate the "install procedure" (assuming you mean AIF interactive procedure, started by /arch/setup - is it really that hard to tell me the name of the command or other "thing you do" ?), you should see an intro dialog, followed by a menu of steps, so that can't be it.
I assume you mean the package installation step in the procedure (is it really that hard to tell me the title of the menu entry you pick?), it just runs pacman.

since you are a TU, you should really learn how to phrase bugreports.
Comment by Thomas Dziedzic (tomd123) - Wednesday, 19 January 2011, 12:07 GMT
  • Field changed: Percent Complete (100% → 0%)
I have a screenshot which would show you what I mean. I honestly thought I was being precise in my description.
Comment by Dieter Plaetinck (Dieter_be) - Wednesday, 19 January 2011, 12:10 GMT
http://ompldr.org/vNzEyOQ/truncated_targets_during_install_procedure.png
in this case, "Targets" is pacman terminology. What you see is just the pacman output (well, part of it), I think it's very unimportant to be able to see the packages again here, because this step gets executed right after *you* selected which packages you want.
Besides, you can always look in pacman.log, this is told to you in the installation guide, and I think by aif itself.

Loading...