AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://projects.archlinux.org/aurweb.git/
Tasklist

FS#22378 - Grass-svn does not build

Attached to Project: AUR web interface
Opened by Huub Munstege (HuMu) - Monday, 10 January 2011, 10:45 GMT
Last edited by Ionut Biru (wonder) - Monday, 10 January 2011, 11:01 GMT
Task Type Bug Report
Category Backend
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version 1.7.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi,
the grass-svn packeage won't build. the PKGBUILD is not anticipated on the python changes.

But also changing the PKGBUILD with the python lines:
"# python2 fix
sed -i 's_python $< $(GISBASE) > $@_python2 $< $(GISBASE) > $@_' gui/wxpython/Makefile
for file in $(find . -name '*.py' -print) gui/wxpython/scripts/d.rast3d.py; do
sed -i 's_^#!.*/usr/bin/python_#!/usr/bin/python2_' $file
sed -i 's_^#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
done"
from the grass-abs PKGBUILD example does not help.

Compiling ends with:
"Errors in:
/home/huub/abs/grass-svn/src/grass64_release/gui/wxpython
--
In case of errors please change into the directory with error and run 'make'.
If you get multiple errors, you need to deal with them in the order they
appear in the error log. If you get an error building a library, you will
also get errors from anything which uses the library.
--
Finished compilation: Mon Jan 10 10:29:30 GMT 2011
make: *** [default] Error 1"

The abs packeage gives the same result
This task depends upon

Closed by  Ionut Biru (wonder)
Monday, 10 January 2011, 11:01 GMT
Reason for closing:  Not a bug
Additional comments about closing:  - For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.
Comment by Huub Munstege (HuMu) - Monday, 10 January 2011, 11:05 GMT
ok is clear. But why is there the AUR option in the drop down menu?

Loading...