Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#22366 - [openssh] Add "--with-libedit" compile option to PKGBUILD

Attached to Project: Arch Linux
Opened by Guillaume ALAUX (galaux) - Sunday, 09 January 2011, 18:58 GMT
Last edited by Ionut Biru (wonder) - Monday, 17 January 2011, 20:36 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To Pierre Schmitz (Pierre)
Aaron Griffin (phrakture)
Thomas Bächler (brain0)
Guillaume ALAUX (galaux)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


When sftp-ing to a server, up/down arrows and TAB keys don't provide expected history and command-completion. Instead arrows display garble text like "^[[A" and TAB displays a tabulation. This can be fixed with the "--with-libedit" compilation option.

Additional info:
Here is a simple diff of the proposed PKGBUILD:

--- PKGBUILD (revision 105507)
+++ PKGBUILD (working copy)
@@ -10,7 +10,7 @@
backup=('etc/ssh/ssh_config' 'etc/ssh/sshd_config' 'etc/pam.d/sshd')
-depends=('openssl' 'zlib' 'pam' 'tcp_wrappers' 'heimdal')
+depends=('openssl' 'zlib' 'pam' 'tcp_wrappers' 'heimdal' 'libedit')
'sshd' 'sshd.confd' 'sshd.pam')
@@ -26,7 +26,7 @@
--sysconfdir=/etc/ssh --with-tcp-wrappers --with-privsep-user=nobody \
--with-md5-passwords --with-pam --with-mantype=man --mandir=/usr/share/man \
--with-xauth=/usr/bin/xauth --with-kerberos5=/usr --with-ssl-engine \
- --disable-strip
+ --with-libedit=/usr/lib --disable-strip
make || return 1

Steps to reproduce:
sftp password:
Connected to
# Press UP arrow
sftp> ^[[A
This task depends upon

Closed by  Ionut Biru (wonder)
Monday, 17 January 2011, 20:36 GMT
Reason for closing:  Implemented
Additional comments about closing:  openssh 5.6p1-2
Comment by Eric Belanger (Snowman) - Sunday, 09 January 2011, 20:26 GMT
That will require moving libedit to core. I also think it would be a nice feature to have.

Guillaume: Aaron hasn't done packaging in years, better assign bug for his packages to the last packager or most active packager according to git log.
Comment by Guillaume ALAUX (galaux) - Sunday, 09 January 2011, 20:30 GMT
All right. I might even make the change myself (including some minor fixes for other bugs) and submit it. Just need to find time for that.
Comment by Eric Belanger (Snowman) - Sunday, 09 January 2011, 20:44 GMT
Before doing that, you should post on ML to see if there are any objections in moving libedit to core to have this feature enabled. Or wait to see what Thomas and Pierre have to say.
Comment by Guillaume ALAUX (galaux) - Sunday, 09 January 2011, 20:47 GMT
All right!
Comment by Thomas Bächler (brain0) - Sunday, 09 January 2011, 21:08 GMT
libedit is small, so this should be fine. I wonder why they don't use readline though.
Comment by Jan de Groot (JGC) - Sunday, 09 January 2011, 22:34 GMT
Because readline is a GPL library, while libedit is BSD-licensed.
Comment by Allan McRae (Allan) - Monday, 10 January 2011, 00:24 GMT
+1 - I would like tab-completion to work in sftp.
Comment by Dan McGee (toofishes) - Monday, 10 January 2011, 04:15 GMT
I might actually use sftp if it had tab completion, so a definite +1 from me.
Comment by Greg (dolby) - Monday, 17 January 2011, 18:59 GMT
openssh now depends on it but libedit is still in extra (flagged out of date)
this should move asap in core cause it breaks installations.
Comment by Ionut Biru (wonder) - Monday, 17 January 2011, 19:23 GMT
and now is in core