Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#22334 - [libreoffice] Cannot edit forms in Libreoffice Base

Attached to Project: Arch Linux
Opened by Jeremy M. (jskier) - Thursday, 06 January 2011, 00:56 GMT
Last edited by Andreas Radke (AndyRTR) - Saturday, 04 June 2011, 14:46 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Form contols won't show even if checked; cannot edit forms created in Base.

Additional info:
* libreoffice-3.3.0.2-3

Steps to reproduce:
Open the Base application.
Create a simple table.
Click on Forms > Create form in Design View...
A blank form with no controls appears (see attached screenshot). Try adding form design or controls- nothing will happen.

Editing older files that have forms will show the forms but there is no way to add or edit form objects. However everything works fine in openoffice-beta. Also, in Libreoffice in Windows (RC2) this is not a problem.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Saturday, 04 June 2011, 14:46 GMT
Reason for closing:  Fixed
Comment by Matěj Týč (bubla) - Friday, 07 January 2011, 16:03 GMT
I don't get it, it looks like that the reason of closing this bug was that it is a duplicate of itself?

BTW it has been reported upstream too with the result "not our bug"
https://bugs.freedesktop.org/show_bug.cgi?id=32796
Comment by Jeremy M. (jskier) - Sunday, 16 January 2011, 22:28 GMT
  • Field changed: Percent Complete (100% → 0%)
This is not a duplicate- 22327 was closed without any mention of this bug (I even mentioned the problem there, no one cares since it is a different bug). Also, as mentioned, this is noted to be "not our bug" in upstream. Please re-open, it was a mistake to close this here.
Comment by Jeremy M. (jskier) - Saturday, 22 January 2011, 17:59 GMT
Still an issue with the latest package update today.
Comment by Andreas Radke (AndyRTR) - Saturday, 29 January 2011, 12:39 GMT
do you use hsqlb or unixodbc to connect? for me it seems to work. have you trieb a clean user profile?
Comment by Jeremy M. (jskier) - Saturday, 29 January 2011, 17:03 GMT
It works for tables and such, it's the Forms section that won't work. Yes, I'm using hsqlb (also tried obdc, same thing) and tried moving my config files for a fresh start- still blank and can't add controls.
Comment by Matěj Týč (bubla) - Tuesday, 01 March 2011, 09:35 GMT
It still doesn't work with libreoffice 3.3.1-1
Comment by Jeremy M. (jskier) - Wednesday, 09 March 2011, 01:05 GMT
It hasn't worked on any of the 8 different workstations I use since I put in this bug report, it's not going to go away with a new version from upstream, it is Arch Linux specific. I use the Oracle package for Base as a "fix" for now. I wish I could help more but I'm not a developer- I'll look over the PKGBUILDs again this week but I don't know what the problem is.
Comment by Andreas Radke (AndyRTR) - Wednesday, 09 March 2011, 07:38 GMT
If it works with other LibO packages it may be indeed a packaging bug. Probably an incompatibility with one of our system libs we use.

You need to find our what code is used in this function. Then we can try to build the LibO pkg using the shipped internal sources for that code. I won't find the time to do this. So please get in touch with the upstream devs either at LibO or even the ones from Oracle. Maybe you can find it out also with searching for similar bugs and what fixes solved them.
Comment by Jeremy M. (jskier) - Wednesday, 09 March 2011, 12:25 GMT
Andreas, can this bug be unassigned then? That way someone who has the time and interest could pick this up.

Was able to find some other similar bugs over at Debian and Ubuntu, all recent occurrences (no resolutions yet)-

http://groups.google.com/group/linux.debian.bugs.dist/browse_thread/thread/c2d666dda4eceaf4?pli=1
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/709778

I am also working on recompiling the build package to the latest version since I haven't done that in awhile (it never seemed to work for me on previous attempts). If I make any progress and find anything out I'll post it here.
Comment by Jeremy M. (jskier) - Wednesday, 23 March 2011, 22:38 GMT
I tried the the testing package today and the forms worked temporarily- this went away on reboot and I can't seem to get them back. Not sure what caused the temporary functionality to return, very odd (did not install any of the extension packages).
Comment by Andreas Radke (AndyRTR) - Thursday, 24 March 2011, 18:32 GMT Comment by Jeremy M. (jskier) - Monday, 30 May 2011, 13:36 GMT
Looks like the issue is optional-outplace-ole.diff. I don't know exactly how to reverse this (trying to figure it out)- however the issue may also be fixed in 3.4. I'd say keep this open until 3.4 fixes it or someone can document how to reverse the problem patch.

https://bugs.freedesktop.org/show_bug.cgi?id=36443
Comment by Jeremy M. (jskier) - Saturday, 04 June 2011, 13:47 GMT
It appears this has been fixed in 3.4.

Loading...