Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#22228 - [kernel26/ drm radeon] problem [drm:drm_mode_getfb] *ERROR* invalid framebuffer id

Attached to Project: Arch Linux
Opened by Victor (only-victor) - Monday, 27 December 2010, 14:00 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 23 October 2011, 16:25 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:

From time to time I have X11 crash with following error:
[drm:drm_mode_getfb] *ERROR* invalid framebuffer id

dmesg|grep drm

[drm] Initialized drm 1.1.0 20060810
[drm] radeon kernel modesetting enabled.
[drm] initializing kernel modesetting (RV710 0x1002:0x9553).
[drm] register mmio base: 0xD6000000
[drm] register mmio size: 65536
[drm] Detected VRAM RAM=512M, BAR=256M
[drm] RAM width 64bits DDR
[drm] radeon: 512M of VRAM memory ready
[drm] radeon: 512M of GTT memory ready.
[drm] radeon: irq initialized.
[drm] GART: num cpu pages 131072, num gpu pages 131072
[drm] Loading RV710 Microcode
[drm] ring test succeeded in 1 usecs
[drm] radeon: ib pool ready.
[drm] ib test succeeded in 0 usecs
[drm] Enabling audio support
[drm] Radeon Display Connectors
[drm] Connector 0:
[drm] VGA
[drm] DDC: 0x7f10 0x7f10 0x7f14 0x7f14 0x7f18 0x7f18 0x7f1c 0x7f1c
[drm] Encoders:
[drm] CRT1: INTERNAL_KLDSCP_DAC1
[drm] Connector 1:
[drm] LVDS
[drm] DDC: 0x7f68 0x7f68 0x7f6c 0x7f6c 0x7f70 0x7f70 0x7f74 0x7f74
[drm] Encoders:
[drm] LCD1: INTERNAL_UNIPHY2
[drm] Connector 2:
[drm] HDMI-A
[drm] HPD1
[drm] DDC: 0x7e40 0x7e40 0x7e44 0x7e44 0x7e48 0x7e48 0x7e4c 0x7e4c
[drm] Encoders:
[drm] DFP1: INTERNAL_UNIPHY
[drm] radeon: power management initialized
[drm] fb mappable at 0xC0142000
[drm] vram apper at 0xC0000000
[drm] size 4325376
[drm] fb depth is 24
[drm] pitch is 5632
fb0: radeondrmfb frame buffer device
drm: registered panic notifier
[drm] Initialized radeon 2.6.0 20080528 for 0000:01:00.0 on minor 0
[drm:drm_mode_getfb] *ERROR* invalid framebuffer id
[drm:drm_mode_getfb] *ERROR* invalid framebuffer id
[drm:drm_mode_getfb] *ERROR* invalid framebuffer id
[drm:drm_mode_getfb] *ERROR* invalid framebuffer id
[drm:drm_mode_getfb] *ERROR* invalid framebuffer id
[drm] Disabling audio support
[drm] ring test succeeded in 1 usecs
[drm] ib test succeeded in 0 usecs
[drm] Enabling audio support
[drm:drm_mode_getfb] *ERROR* invalid framebuffer id
[drm] Disabling audio support
[drm] ring test succeeded in 1 usecs
[drm] ib test succeeded in 0 usecs
[drm] Enabling audio support
[drm:drm_mode_getfb] *ERROR* invalid framebuffer id
[drm] Disabling audio support
[drm] ring test succeeded in 1 usecs
[drm] ib test succeeded in 0 usecs
[drm] Enabling audio support
[drm:drm_mode_getfb] *ERROR* invalid framebuffer id
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 23 October 2011, 16:25 GMT
Reason for closing:  No response
Comment by Louis Turk (drl) - Tuesday, 28 December 2010, 12:40 GMT
I'm having this problem also. It occurs often at night when the computer is not being used.
Comment by Louis Turk (drl) - Tuesday, 28 December 2010, 12:42 GMT
Last 3 lines of dmesg:

[drm:radeon_dvi_detect] *ERROR* HDMI Type A-1: probed a monitor but no|invalid EDID
[drm:drm_mode_getfb] *ERROR* invalid framebuffer id
[drm:drm_mode_getfb] *ERROR* invalid framebuffer id
Comment by Spartan Roc (spartanroc) - Wednesday, 05 January 2011, 15:29 GMT
I have a similar but much more severe problem:
Xorg crashes every few seconds or minutes randomly and goes back to gdm login screen. Each time it happens right after the same error in /var/log/errors.log or by dmesg | grep -i drm, [drm:drm_mode_getfb] *ERROR* invalid framebuffer id

This problem started Jan. 04, 2011 when I run pacman -Syu so I have a up-to-date system. In particular it installed xorg-server-1.9.2-2. I tried different kernel versions ranging from 2.6.32 to the newest one 2.6.36. The problem is the same. It makes the machine unusable.

Then I decided to revert back to xorg-server-1.8.1.902-1 which is the one I used before the problem. I downgraded several other related xorg packages as well:
[2011-01-04 18:20] Running 'pacman -R xorg-server-common xorg-server'
[2011-01-04 18:20] removed xorg-server (1.9.2-2)
[2011-01-04 18:20] removed xorg-server-common (1.9.2-2)
[2011-01-04 18:21] Running 'pacman -U xorg-server-1.8.1.902-1-i686.pkg.tar.xz'
[2011-01-04 18:23] Running 'pacman -R xf86-input-evdev xf86-input-keyboard xf86-input-mouse xf86-video-ati xf86-video-vesa'
[2011-01-04 18:23] removed xf86-video-vesa (2.3.0-3)
[2011-01-04 18:23] removed xf86-video-ati (6.13.2-2)
[2011-01-04 18:23] removed xf86-input-mouse (1.6.0-1)
[2011-01-04 18:23] removed xf86-input-keyboard (1.4.0-3)
[2011-01-04 18:23] removed xf86-input-evdev (2.5.0-1)
[2011-01-04 18:26] Running 'pacman -U xorg-server-1.8.1.902-1-i686.pkg.tar.xz xf86-video-vesa-2.3.0-2-i686.pkg.tar.xz xf86-video-ati-6.13.0-1-i686.pkg.tar.xz xf86-input-mouse-1.5.0-2-i686.pkg.tar.xz xf86-input-keyboard-1.4.0-2-i686.pkg.tar.xz xf86-input-evdev-2.4.0-1-i686.pkg.tar.xz'
[2011-01-04 18:26] installed xf86-input-evdev (2.4.0-1)
[2011-01-04 18:26]
[2011-01-04 18:26] Input device handling has changed since xorg-server 1.5.
[2011-01-04 18:26] Please read http://wiki.archlinux.org/index.php/Xorg_input_hotplugging.
[2011-01-04 18:26]
[2011-01-04 18:26] installed xorg-server (1.8.1.902-1)
[2011-01-04 18:26] installed xf86-video-vesa (2.3.0-2)
[2011-01-04 18:26] installed xf86-video-ati (6.13.0-1)
[2011-01-04 18:26] installed xf86-input-mouse (1.5.0-2)
[2011-01-04 18:26] installed xf86-input-keyboard (1.4.0-2)
So far everything's been running very stably. I don't know what exactly caused the problem. I googled the web and it surprised me that not many people are complaining about this bug. It is so nasty I would not upgrade to >1.9 xorg before this bug got fixed.

Here is the information related to my machine:
lspci | grep -i radeon
01:00.0 VGA compatible controller: ATI Technologies Inc RV630 [Radeon HD 2600XT]

Comment by Spartan Roc (spartanroc) - Wednesday, 05 January 2011, 15:35 GMT
BTW, I don't have any manual settings for Xorg, i.e., no xorg.conf file. I use xorg's auto-detection and it works fine for me.
Comment by ... (spider007) - Wednesday, 12 January 2011, 09:10 GMT
I experience the same problem when visiting sites that use jQuery's fancybox. It is pretty reproducable for me, so if I can generate extra information to resolve this please let me know


01:00.0 VGA compatible controller: ATI Technologies Inc M76XT [Mobility Radeon HD 2600 XT]
Comment by Ronan Arraes Jardim Chagas (Ronis_BR) - Tuesday, 15 February 2011, 17:43 GMT
Hi guys,

A strange thing, I have two PCs with radeon, one I got this problem and the other is just fine.
The behavior is exactly the same: X crashes randomly going back to GDM and I got at dmesg [drm:drm_mode_getfb] *ERROR* invalid framebuffer id.

Does anyone have any ideas what is happening?
Comment by Jean-Charles (pralines) - Wednesday, 16 February 2011, 16:03 GMT
Hi

Same message (and exit to gdm) with xorg 1.9.4 (x86_64 arch) + dual monitor config (not clone)
problem disappeared with xorg 1.8.1 (or if i configure dual monitor in clone mode)

lspci | grep -i radeon
01:00.0 VGA compatible controller: ATI Technologies Inc RV570 [Radeon X1950 Pro] (rev 9a)
01:00.1 Display controller: ATI Technologies Inc RV570 [Radeon X1950 Pro] (secondary) (rev 9a)

no xorg.conf
Comment by Ronan Arraes Jardim Chagas (Ronis_BR) - Tuesday, 15 March 2011, 14:49 GMT
Hi fellows!
Does anyone have any news about this bug?
I think it should be changed from unconfirmed to confirmed, shouldn't it?

Btw, my problem here is very "stochastic" and I wasn't able to find a pattern to reproduce it. Can anyone who knows a procedure to reproduce it install another Linux distro, e.g. Ubuntu, and verify if it happens? We need to verify if it is caused by something with Arch Linux or if it is upstream problem.

Regards,
Ronan.
Comment by Ronan Arraes Jardim Chagas (Ronis_BR) - Thursday, 17 March 2011, 19:57 GMT
Hi fellows!

I have updated my ArchLinux today (Xorg 1.9.4.901 and Kernel 2.6.38) from testing repository.
I also have updated all video related things including xf86-video-ati package and the problem seems to be gone, since I have been using my PC for more than 2 hours without a single crash.

Can you guys confirm this?
Comment by Jean-Charles (pralines) - Thursday, 17 March 2011, 20:44 GMT
Hi

last time i checked, with kernel 2.6.37 and Xorg 1.9.4.901 the problem persist with ati in dual screen (not clone),
i'm a little affraid to test with 2.6.38, it's my prod machine and i don't master arch, have work to finish for tomorrow...
(i will try with kernel 2.6.38 this week-end, after the cloning of my hd ;-)
Comment by Ronan Arraes Jardim Chagas (Ronis_BR) - Friday, 25 March 2011, 16:55 GMT
Hi fellow,

I really think you should try 2.6.38 with the latest mesa and xf86-video-ati available in official Arch repos.
I have been using it for the past 7 days without a single crash!
Comment by Andreas Radke (AndyRTR) - Thursday, 31 March 2011, 16:37 GMT
That is more likely a kernel-drm issue. Check various kernels and maybe drm-next/testing from AUR. Adding also our kernel maintainer here. [Ati] is not really helpful in the topic.
Comment by Jelle van der Waa (jelly) - Thursday, 16 June 2011, 10:23 GMT
more luck with .39?
Comment by Andreas Radke (AndyRTR) - Monday, 22 August 2011, 05:50 GMT
Nothing has been reported upstream. I'm going to close this soon because it's no packaging bug.

Loading...