Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#22200 - [flashplugin] add optdepends for pulseaudio sw mixing support

Attached to Project: Community Packages
Opened by Babets (Babets) - Thursday, 23 December 2010, 20:57 GMT
Last edited by Ionut Biru (wonder) - Saturday, 19 February 2011, 12:09 GMT
Task Type Feature Request
Category Packages
Status Closed
Assigned To Florian Pritz (bluewind)
Jan Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Without the installation of lib32-alsa-plugins and lib32-libcanberra-pulse when you open e.g. a youtube video and another application that use the audio (such as mumble), you are not able to listen both of them using pulseaudio (at least in gnome).
Add these packages as optdepends for flashplugin (x86_64 only of course):

'lib32-alsa-plugins: for pulseaudio software mixing support'
'lib32-libcanberra-pulse: for pulseaudio software mixing support'

Additional info:
* package version(s): 10.1.102.65-1 (multilib)


Steps to reproduce:
Launch mumble and connect it to a server;
Open firefox and watch a video.
This task depends upon

Closed by  Ionut Biru (wonder)
Saturday, 19 February 2011, 12:09 GMT
Reason for closing:  Not a bug
Additional comments about closing:  flashplugin uses alsa
Comment by Babets (Babets) - Thursday, 23 December 2010, 21:09 GMT
I added this suggestion into the pulseaudio wiki page: https://wiki.archlinux.org/index.php/Pulseaudio#Flashplugin_.28x86_64_only.29
Comment by Jan Steffens (heftig) - Thursday, 23 December 2010, 22:42 GMT
The wiki page is the right place for this, not optdepends.
Comment by Babets (Babets) - Friday, 24 December 2010, 09:34 GMT
"optdepends: An array of package names that are not needed for the software to function but provides additional features" from https://wiki.archlinux.org/index.php/PKGBUILD in this case software mixing.
Comment by Jan Steffens (heftig) - Friday, 24 December 2010, 12:41 GMT
flashplugin simply uses ALSA, it doesn't care about PulseAudio. Hence, not an optdepend.
Comment by Babets (Babets) - Friday, 24 December 2010, 13:17 GMT
Ok, now I understand, so IMHO these packages should be an optdepend for pulseaudio on x86_64, so every 32bits package that uses plain alsa (with pulseaudio installed) doesn't lock the soundcard. :)

Anyway I made some tests:

- gnome without pulseaudio with firefox using flash and rhythmbox up and running:
tk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: cannot open shared object file: No such file or directory
Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: cannot open shared object file: No such file or directory
Gtk-Message: Failed to load module "gnomesegvhandler": libgnomesegvhandler.so: cannot open shared object file: No such file or directory
*** NSPlugin Viewer *** WARNING: unhandled variable 18 (<unknown variable>) in NPN_GetValue()
*** NSPlugin Viewer *** WARNING: unhandled variable 18 (<unknown variable>) in NPN_GetValue()
NOTE: child process received `Goodbye', closing down

(software mixing working, flashplugin and rhythmbox are able to access the soundcard in the same time).

- gnome with pulseaudio with firefox using flash and rhythmbox up and running:
tk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: cannot open shared object file: No such file or directory
Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: cannot open shared object file: No such file or directory
Gtk-Message: Failed to load module "gnomesegvhandler": libgnomesegvhandler.so: cannot open shared object file: No such file or directory
*** NSPlugin Viewer *** WARNING: unhandled variable 18 (<unknown variable>) in NPN_GetValue()
*** NSPlugin Viewer *** WARNING: unhandled variable 18 (<unknown variable>) in NPN_GetValue()
ALSA lib pcm.c:2171:(snd_pcm_open_conf) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so
NOTE: child process received `Goodbye', closing down

(no software mixing, only flashplugin is accessing the soundcard)

- same thing with lib32-alsa-plugin installed;

- adding lib32-libpulse allows software mixing but the error about libcanberra is still here (but this seems it doesn't cause problems).

Loading...