Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#22196 - [logwatch] package is missing a dependency on perl-date-manip

Attached to Project: Community Packages
Opened by Wade Carpenter (wade) - Thursday, 23 December 2010, 06:52 GMT
Last edited by Sergej Pupykin (sergej) - Thursday, 23 December 2010, 11:38 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When trying to use a 'range' option value other than 'yesterday', 'today', or 'all', logwatch gives an error message, e.g.

ERROR: Range "since yesterday" not understood

This system does not have Date::Manip module loaded, and therefore
the only valid --range parameters are 'yesterday', 'today', or 'all'.
The Date::Manip module can be installed by using either of:
apt-get install libdate-manip-perl (recommended on Debian)'
cpan -i 'Date::Manip'
perl -MCPAN -e 'install Date::Manip'


Additional info:
* package version(s)
7.3.6-4

* config and/or log files etc.
default config

Steps to reproduce:
Without perl 'Date::Manip' installed, run:
logwatch --range 'since yesterday'
This task depends upon

Closed by  Sergej Pupykin (sergej)
Thursday, 23 December 2010, 11:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  added to optdepends

Loading...