Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#22102 - pacman 3.4.1-1 segfault

Attached to Project: Pacman
Opened by Julien Pecqueur (jpec) - Tuesday, 14 December 2010, 18:53 GMT
Last edited by Dan McGee (toofishes) - Wednesday, 15 December 2010, 17:31 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To Dan McGee (toofishes)
Architecture All
Severity Critical
Priority Normal
Reported Version 3.4.1
Due in Version 3.4.2
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
pacman segfaults when updating

Additional info:
* package version(s) pacman 3.4.1-1 i686
* config and/or log files etc.
default pacman.conf

Steps to reproduce: pacman -Syu

Watch the dump attached.
This task depends upon

Closed by  Dan McGee (toofishes)
Wednesday, 15 December 2010, 17:31 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Dupe of  FS#21668 , fix in git waiting for release.
Comment by Dan McGee (toofishes) - Tuesday, 14 December 2010, 22:11 GMT
Probably the same as what we fixed in  FS#21668 . To work around, comment out the Architecture= line in your pacman.conf and let us know if that "solves" it.
Comment by Julien Pecqueur (jpec) - Tuesday, 14 December 2010, 22:22 GMT
I try it and it don't work (i got an error about the $arch variable not configured, so i try to put Architecture=i686 but i got the segfault too).
Comment by Xavier (shining) - Tuesday, 14 December 2010, 22:30 GMT
You need to replace manually $arch by i686 for the mirror / Server you use in the mirror file.

Alternatively you can also send us a tarball of /var/lib/pacman for inspection.

Or you can try to get a gdb backtrace with debug symbols if you know how.
Comment by Julien Pecqueur (jpec) - Tuesday, 14 December 2010, 22:40 GMT
Here is my /var/lib/pacman

EDIT: file too big so i uploaded it here :
http://julienpecqueur.com/pacman_lib.tar.gz
Comment by Xavier (shining) - Tuesday, 14 December 2010, 22:53 GMT
thanks.
can you run 'pacman -Syy' and try again ?
Comment by Julien Pecqueur (jpec) - Wednesday, 15 December 2010, 10:56 GMT
I'll try it this evening !
Comment by Julien Pecqueur (jpec) - Wednesday, 15 December 2010, 17:22 GMT
I've done it and now it's ok! thank you.
Comment by Julien Pecqueur (jpec) - Wednesday, 15 December 2010, 17:24 GMT
So i don't have anymore the segfault. Does i have to close the bug or i keepit for the segault in case the database of pacman is dirty?

Loading...