Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#22071 - [mpd] 0.16 missing tcp_wrappers dependancy

Attached to Project: Arch Linux
Opened by Mark Foxwell (fastfret79) - Sunday, 12 December 2010, 15:19 GMT
Last edited by Angel Velasquez (angvp) - Wednesday, 15 December 2010, 20:58 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Angel Velasquez (angvp)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:

mpd 0.16 should have a tcp_wrappers dependancy and needs an entry in hosts.allow for the mpd to start correctly.

After upgrading mpd to 0.16 I was unable to connect with my mpd client (ncmpcpp). After enabling verbose logging in the mpd.conf, I get the following errors in the mpd.log:

Dec 12 13:50 : avahi: Initializing interface
Dec 12 13:50 : avahi: Client changed to state 101
Dec 12 13:50 : avahi: Client is CONNECTING
Dec 12 13:50 : state_file: Loading state file /var/lib/mpd/mpdstate
Dec 12 13:51 : client: libwrap refused connection (libwrap=mpd) from 127.0.0.1:54755
Dec 12 13:51 : client: libwrap refused connection (libwrap=mpd) from 127.0.0.1:54756
Dec 12 13:51 : client: libwrap refused connection (libwrap=mpd) from 127.0.0.1:54761

After adding mpd to hosts.allow, the mpd daemon starts correctly and I am able to connect with my client.
This task depends upon

Closed by  Angel Velasquez (angvp)
Wednesday, 15 December 2010, 20:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 0.16-2
Comment by Angel Velasquez (angvp) - Sunday, 12 December 2010, 22:12 GMT
tcp_wrappers is on base group ([core]), so I don't think it should be added as a dependency.

And mpd always needed to be in hosts.allow (see here [1]), did you a fresh install and got the upgrade? seems that you didn't running mpd then did an upgrade and tried it, it's working perfectly here.

So this is not a bug :/, thanks for testing the new version anyway.

[1] https://wiki.archlinux.org/index.php/MPD

Comment by xduugu (xduugu) - Sunday, 12 December 2010, 22:22 GMT
[1] says:
> Remember to add mpd to the /etc/hosts.allow file to enable external access.

So apparently, it was always required in some cases, but it worked fine for localhost before 0.16 without this hosts.allow entry.


[1] https://wiki.archlinux.org/index.php/MPD
Comment by Mark Foxwell (fastfret79) - Sunday, 12 December 2010, 22:49 GMT
As xduugu said, adding mpd to hosts.allow was only needed for external access - previous versions (0.15.15 and below) did not need it for local use.

I've been using mpd perfectly for about 1.5 years without having mpd in hosts.allow and I think a lot of other users will have the same problem after upgrading.

Didn't realise that tcp_wrappers is part of the base group, so adding as a dependancy would be unnecessary.
Comment by Angel Velasquez (angvp) - Sunday, 12 December 2010, 23:28 GMT
Oh I thought you're using through a network, certainly it doesn't have sense to add an entry on hosts.allow if you will use localy.

I don't have anything on hosts.allow since I don't use it from another machine on the network, and I am using the same client as you and it's working smooth, so I think isn't an upgrade issue that you're having, or anybody else had to add an entry on hosts.allow too? could you paste your hosts.conf config ? and your mpd configs? to figure out?
Comment by Mark Foxwell (fastfret79) - Monday, 13 December 2010, 00:32 GMT
My mpd.conf is here: http://pastebin.com/Mk8vZxMv

my host.conf only has the following:

order hosts,bind
multi on
Comment by Dan McGee (toofishes) - Monday, 13 December 2010, 01:15 GMT
Just remove the sh** that is libwrap from here would be my "totally unbiased" preference- can you compile with --disable-libwrap or something? No current system uses this broke method of firewalling services.
Comment by Mark Foxwell (fastfret79) - Wednesday, 15 December 2010, 12:36 GMT
I guess this can be closed now that 0.16-2 is compiled with --disable-libwrap

Loading...