Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#22068 - [libvirt] needs /usr/bin/nc -> /usr/bin/nc.openbsd

Attached to Project: Community Packages
Opened by Yannick Loth (yannick555) - Sunday, 12 December 2010, 10:27 GMT
Last edited by Sergej Pupykin (sergej) - Tuesday, 25 January 2011, 16:34 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I tried to remote connect to a remote ArchLinux VM host server (which uses libvirt/kvm) using virt-manager (qemu+ssh), from Ubuntu 10.10. An error message says that 'nc' is not found.

I solved the bug by executing on the ArchLinux server: ln -s /usr/bin/nc.openbsd /usr/bin/nc

Maybe this link should be created when installing libvirt, or some config file from libvirt should point to the right command.

Additional info:
* package version(s)
libvirt 0.8.5-2
openbsd-netcat 1.89-4

* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Sergej Pupykin (sergej)
Tuesday, 25 January 2011, 16:34 GMT
Reason for closing:  No response
Additional comments about closing:  Anyway it can be fixed with gconf-editor. Probably upstream will implement it in UI
Comment by Sergej Pupykin (sergej) - Sunday, 12 December 2010, 21:22 GMT
Did you try latest libvirt 0.8.6-2?
It should always optdepend on openbsd-netcat now.
Comment by Gris Ge (cathay4t) - Tuesday, 14 December 2010, 06:49 GMT
virt-manager in archlinux cannnot connect to RHEL 6 libvirtd as RHEL 6 is using nc instead of nc.openbsd.

Workaround:
Excute this command on RHEL 6 server:
sudo ln -s /usr/bin/nc /usr/bin/nc.openbsd

I don't whether this is RHEL bug or archlinux bug.
It seems that we (archlinux) should use nc instead of nc.openbsd
Comment by Sergej Pupykin (sergej) - Tuesday, 14 December 2010, 10:49 GMT
Please try to open gconf-editor and edit /apps/virt-manager/connections/uris

add to your RHEL uri following text: ?netcat=/usr/bin/nc

so uri looks like:

qemu+ssh://user@host/system?netcat=/usr/bin/nc

I cannot find how to do it from virt-manager UI.

Loading...