Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#22066 - [glibc] getaddrinfo assertion triggered without reason

Attached to Project: Arch Linux
Opened by Mike Massonnet (m8t) - Sunday, 12 December 2010, 09:47 GMT
Last edited by Allan McRae (Allan) - Sunday, 23 January 2011, 23:37 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Allan McRae (Allan)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi,

Description:
When running "httpd -k start" it always fails to start.

Additional info:
- apache package version 2.2.17-1

- [2010-12-09 20:52] upgraded glibc (2.12.1-3 -> 2.12.1-4)
Apache used to work fine and I believe this update has screwed things up.

- /var/log/httpd/error_log:
httpd: ../sysdeps/posix/getaddrinfo.c:1466: rfc3484_sort: Assertion `src->results[i].native == -1 || src->results[i].native == a2_native' failed.

Thanks for looking into this,
Mike
This task depends upon

Closed by  Allan McRae (Allan)
Sunday, 23 January 2011, 23:37 GMT
Reason for closing:  Works for me
Additional comments about closing:  If a bug is still there, it is an upstream one. See comments.
Comment by Allan McRae (Allan) - Sunday, 12 December 2010, 09:57 GMT
Post your /etc/hosts. This issues tend to result from configurations issues there...
Comment by Mike Massonnet (m8t) - Sunday, 12 December 2010, 16:00 GMT
$ cat /etc/hosts
#
# /etc/hosts: static lookup table for host names
#
192.168.0.10 miky # Added by NetworkManager
127.0.0.1 localhost.localdomain localhost
::1 miky localhost6.localdomain6 localhost6

#<ip-address> <hostname.domain.org> <hostname>
127.0.1.1 miky
Comment by Allan McRae (Allan) - Tuesday, 14 December 2010, 12:40 GMT Comment by Mike Massonnet (m8t) - Thursday, 20 January 2011, 20:59 GMT
Meh, sorry. I didn't notice the mail where you suggested this.

I recently updated the packages again and today running the httpd services works again, even by keeping the 127.0.1.1 line in the hosts file.

I can't tell if this was or not related to glibc, Apache is still the same version :(

[2011-01-01 19:02] upgraded glibc (2.12.1-4 -> 2.12.2-1)


Kind Regards
Comment by Allan McRae (Allan) - Friday, 21 January 2011, 10:17 GMT
So I can close this now?
Comment by Mike Massonnet (m8t) - Sunday, 23 January 2011, 16:35 GMT
Sure, I can't reproduce it anymore.

Loading...