Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#22055 - [nvidia] Screen turns off on start up, though nothing crashes!!

Attached to Project: Arch Linux
Opened by Halim Can Albasan (sultanhalim) - Saturday, 11 December 2010, 16:12 GMT
Last edited by Andrea Scarpino (BaSh) - Thursday, 16 December 2010, 19:10 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
I made a full system upgrade (pacman -Syu) after months, and pretty much everything is upgraded. And when I rebooted the system, right when X starts and kdm screen must show up, the screen turns off (not goes black; turns off as if I shut down the system). The problem might be related to the upgrades of the kernel26 (2.6.36.1-3), and the nvidia driver (260.19.21-2).

$ lspci
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 02)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IR (ICH9R) LPC Interface Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 6 port SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation G86 [GeForce 8400 GS] (rev a1)
03:00.0 SATA controller: JMicron Technology Corp. JMB362/JMB363 Serial ATA Controller (rev 02)
03:00.1 IDE interface: JMicron Technology Corp. JMB362/JMB363 Serial ATA Controller (rev 02)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
05:02.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)
The stupid thing to do was, because I was running out of space on my hardisk, I did "pacman -Sc" and got rid of the old packages in the cache, so I don't have the older versions available.

Additional info:
* kernel26 2.6.36.1-3 (base) [installed]
* nvidia 260.19.21-2 [installed]
* see dmesg on http://pastebin.com/YuDxfsmC
* see pacman.log attached.

Note that nothing crashes, kdm seems to start without errors, or warnings, just the screen turns off. Tried it with my old xorg.conf, which was working without any problem; without xorg.conf; and with the xorg.conf that nvidia-xconfig created. Result is always the same. Screen works with vesa driver, but of course with a low resolution (800x600). I have been using resolution "1024x768"; my screen is an old crt, Philips 107e6.

Steps to reproduce:
Start X, as in startup, or "/etc/rc.d/kdm start", or "startx"
   pacman.log (239.8 KiB)
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Thursday, 16 December 2010, 19:10 GMT
Reason for closing:  Not a bug
Additional comments about closing:  user said: solved
Comment by Halim Can Albasan (sultanhalim) - Sunday, 12 December 2010, 00:25 GMT
Attached are my xorg.conf and my Xorg.0.log, when the error occurs, if it helps...

P.S. The warnings present in the Xorg.0.log, are also present with the vesa driver.. For any other needs, please respond.. Thanks in advance...
Comment by Halim Can Albasan (sultanhalim) - Thursday, 16 December 2010, 19:06 GMT
http://www.nvnews.net/vbulletin/showpost.php?p=2365591&postcount=11

Adding;
Option "ConnectedMonitor" "CRT-1"
in the "Device" section where the graphics card is introduced really solves this..

Interesting that, after all the work done for EDID and stuff, one may think the upgrades were going in the direction where we wouldn't be needing xorg.conf anymore; now with this last upgrade, we are dependent on the xorg.conf again for this specific option!!

I guess this turned out to be an issue about [X] in stead of [nvidia]; maybe we should edit the title..

Loading...