AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://projects.archlinux.org/aurweb.git/
Tasklist

FS#22040 - Incorrect parsing of pkgdesc containing #

Attached to Project: AUR web interface
Opened by Byron Clark (byronc) - Friday, 10 December 2010, 15:10 GMT
Last edited by Lukas Fleischer (lfleischer) - Friday, 21 January 2011, 06:31 GMT
Task Type Bug Report
Category PKGBUILD Parser
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 1.7.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

The PKGBUILD for thrift (http://aur.archlinux.org/packages.php?ID=33213) contains this line:
pkgdesc="Scalable cross-language services framework for IPC/RPC between C++, Java, Ruby, PHP, Python, C#, Haskell, Erlang, etc."

In the web interface, the description is shown as
"Scalable cross-language services framework for IPC/RPC between C++, Java, Ruby, PHP, Python, C

It appears the PKGBUILD parser is interpreting the # inside the quotes as the start of a comment.
This task depends upon

Closed by  Lukas Fleischer (lfleischer)
Friday, 21 January 2011, 06:31 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Dupe of  FS#15043 .
Comment by Lukas Fleischer (lfleischer) - Tuesday, 11 January 2011, 08:38 GMT
This is kinda a dupe of  FS#17482  and  FS#17328 . I propsed a fix somewhere in the comments there but I'm not sure whether we're gonna push that at all.

Loading...