Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21962 - [blender] wont open after python update

Attached to Project: Arch Linux
Opened by farid (osc) - Thursday, 02 December 2010, 14:02 GMT
Last edited by Ionut Biru (wonder) - Friday, 03 December 2010, 14:00 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Compiled with Python version 2.7.
Traceback (most recent call last):
File "/usr/lib/python2.7/site.py", line 62, in <module>
import os
File "/usr/lib/python2.7/os.py", line 398, in <module>
import UserDict
File "/usr/lib/python2.7/UserDict.py", line 83, in <module>
import _abcoll
File "/usr/lib/python2.7/_abcoll.py", line 11, in <module>
from abc import ABCMeta, abstractmethod
File "/usr/lib/python2.7/abc.py", line 8, in <module>
from _weakrefset import WeakSet
File "/usr/lib/python2.7/_weakrefset.py", line 5, in <module>
from _weakref import ref
ImportError: No module named _weakref


Additional info:
* package version(s)

blender 2.49b-1
python2 2.7.1-2

* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Ionut Biru (wonder)
Friday, 03 December 2010, 14:00 GMT
Reason for closing:  Fixed
Additional comments about closing:  blender-2.49b-2
Comment by Lukas Jirkovsky (6xx) - Thursday, 02 December 2010, 15:17 GMT
Confirming.
Comment by Ionut Biru (wonder) - Thursday, 02 December 2010, 16:14 GMT
try blender-2.49b-2. it should hit repos soon
Comment by St├ęphane Gaudreault (stephane) - Friday, 03 December 2010, 12:45 GMT
blender-2.49b-2 works for me.

Loading...