Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers
Tasklist

FS#21940 - Beginners guide / AIF "3. Prepare Harddrive(s)" menu does not describe dangers

Attached to Project: Release Engineering
Opened by Mr. K. (KitchM) - Tuesday, 30 November 2010, 19:10 GMT
Last edited by Dieter Plaetinck (Dieter_be) - Thursday, 09 December 2010, 07:33 GMT
Task Type Bug Report
Category AIF
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version 2010.05.16-testbuild
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:The installation routine gives a number of steps thru the use of the menu system. The section regarding the partitioning of the hard drive fails to clearly define which selection is non-destructive. This is a serious problem for those desiring to simply recover their system from a bad upgrade or similar. There is also no warning as given in the Beginners' Guide where it warns to use Ctrl-C rather than Cancel.


Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:Boot off of the Arch install CD, log in as root, run the setup routine, select the steps in order on the menu, get to "3. Prepare Harddrive(s)". Note the missing warnings and explanation.
This task depends upon

Closed by  Dieter Plaetinck (Dieter_be)
Thursday, 09 December 2010, 07:33 GMT
Reason for closing:  Works for me
Comment by Dieter Plaetinck (Dieter_be) - Thursday, 09 December 2010, 07:32 GMT
The official installation guide cleary states for each menu entry what it does, including if and when it makes changes.
it's available as https://wiki.archlinux.org/index.php/Official_Arch_Linux_Install_Guide
and on the LiveCD itself (as told to you when you login)

The beginners guide is not official in any way, it's a community document. feel free to update it yourself

Loading...