Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#21927 - [kernel26] drm:intel_prepare_page_flip, *ERROR* Prepared flip multiple times

Attached to Project: Arch Linux
Opened by Maxwell Draven (Ravenman) - Monday, 29 November 2010, 20:50 GMT
Last edited by Tobias Powalowski (tpowa) - Tuesday, 14 February 2012, 14:35 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan de Groot (JGC)
Thomas Bächler (brain0)
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No



Today, I have upgraded the operative system of one workstation, and after from the first reboot, the KDE draws everything slowly. The operative system generates big log files (I have one log directory with 500 MB of size ... and growing!)

Additional info:
* package version(s)


xorg-server 1.9.2-2

xf86-video-intel 2.13.0-4

kdebase-workspace 4.5.3-1

* config and/or log files etc.

The log files are very big, but this line is common in everyone:

[drm:intel_prepare_page_flip] *ERROR* Prepared flip multiple times

Steps to reproduce:

Update Xorg server, intel drivers and kernel in a desktop computher with one Intel Corporation 82865G Integrated Graphics Controller VGA card.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Tuesday, 14 February 2012, 14:35 GMT
Reason for closing:  Fixed
Comment by Viktor (delusion) - Tuesday, 30 November 2010, 12:04 GMT
After update i got the same bug. In dmesg log many times appears this line "[drm:intel_prepare_page_flip] *ERROR* Prepared flip multiple times", program using opengl became slow work (for example KDE screensaver).
I'm try to downgrade kernel to old 2.6.35 version and bug has disappered. Maybe a bug in new kernel?
Comment by mkkot (mkkot) - Thursday, 02 December 2010, 13:48 GMT
Same here. I have an IBM Thinkpad x30 with an Intel Almador(830MG) graphics card. I run lightweight system with Xfce. Something strange happened after yesterdays upgrade. Finally I realised it's the full root partition. After removing appriopriate logs and restarting syslog-ng I extracted what caused the problem: fullscreen MatrixGL screensaver from xscreensaver's package. So I guess the new kernel must have broken something within 3D support.
Comment by mkkot (mkkot) - Thursday, 02 December 2010, 14:12 GMT Comment by Norbert (Pusi85) - Tuesday, 07 December 2010, 13:13 GMT
I have the same problem.

My machine is a Dell Workstation computer with a 82865G Integrated Graphics Controller.
[root@Archos ~]# uname -a
Linux Archos 2.6.36-ARCH #1 SMP PREEMPT Wed Nov 24 06:44:11 UTC 2010 i686 Intel(R) Pentium(R) 4 CPU 2.60GHz GenuineIntel GNU/Linux

I have huge .log files:
1,3G /var/log/errors.log
1,3G /var/log/kernel.log
1,4G /var/log/everything.log

They all have a lot of the same lines:
errors.log & kernel.log:
Dec 7 11:52:00 localhost kernel: [drm:intel_prepare_page_flip] *ERROR* Prepared flip multiple times
Dec 7 13:12:26 localhost syslog-ng[1193]: Error suspend timeout has elapsed, attempting to write again; fd='8'

My /var partition is full! (4,1GB)
Comment by Norbert (Pusi85) - Thursday, 09 December 2010, 15:19 GMT
Hi, all!

I've did a clean install.
The problem is still present. My log files grow huge, when I watch youtube:
4,0K errors.log
1,1G errors.log.tmp
688K everything.log
1,2G everything.log.tmp
616K kernel.log
1,1G kernel.log.tmp
(The *.tmp file are the ones, with the reoccuring lines, the small .log files are without them.)

I have xf86-video-vesa, xf86-video-fbdev, xf86-video-intel and xf86-video-vesa drivers installed. I'll try to uninstall the *intel driver, to force it to use *vesa.

My machine is still a Dell Workstation computer with a 82865G Integrated Graphics Controller.
[root@DarkArch ~]# uname -a
Linux DarkArch 2.6.36-ARCH #1 SMP PREEMPT Wed Nov 24 06:44:11 UTC 2010 i686 Intel(R) Pentium(R) 4 CPU 2.60GHz GenuineIntel GNU/Linux

Comment by Thomas Bächler (brain0) - Thursday, 09 December 2010, 15:30 GMT
This is likely not a regression. In the past, we disabled page flipping in the Xorg driver because of the many kernel bugs it exposes. The 2.13 series of xf86-video-intel is the first version that has it enabled. Try reverting to the 2.12 series Arch packages and see what happens. We might have to patch the driver again to disable page flipping - I wonder why Intel is not fixing these bugs and especially ignores the above bug report.
Comment by Viktor (delusion) - Thursday, 09 December 2010, 19:53 GMT
Hi! With xf86-video-intel 2.12.0-3 and kernel works fine for me, thanks (00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)).
Comment by Thomas Bächler (brain0) - Thursday, 09 December 2010, 23:21 GMT
Jan, what do we do? Disable page flipping yet again in the latest driver?
Comment by Norbert (Pusi85) - Friday, 10 December 2010, 05:27 GMT
Hi, everyone!

I've bypassed the problem by disabling DRI altogether. I've inserted the option into a new file:
/etc/X11/xorg.conf.d/10-intel.conf (see attached file).

Is there an easy way to disable page flipping only?
My 82865G Integrated Graphics Controller works with the xf86-video-vesa driver as well, but only in low resolution.


[root@DarkArch ~]# uname -a
Linux DarkArch 2.6.36-ARCH #1 SMP PREEMPT Wed Nov 24 06:44:11 UTC 2010 i686 Intel(R) Pentium(R) 4 CPU 2.60GHz GenuineIntel GNU/Linux
[root@DarkArch ~]# pacman -Qs kernel26 xf86-video-intel
local/kernel26 (base)
The Linux Kernel and modules
local/xf86-video-intel 2.13.0-4 (xorg-video-drivers) Intel i810/i830/i915/945G/G965+ video drivers

It uses the i915 part of the driver.

Hope it helps!

Comment by Maxwell Draven (Ravenman) - Friday, 21 January 2011, 17:02 GMT
Would this be helpful?: (Comment #10)
Comment by Ghodmode (Ghodmode) - Thursday, 21 April 2011, 14:38 GMT
Following Thomas Bächler's advice, I downgraded from 2.15.0-1 to 2.12.0-3 and it fixed the problem for a while.

After an upgrade of Xorg, I can't use an external monitor (it's a laptop) and found this error in /var/log/Xorg.0.log ...

[ 15.823] (II) Module intel: vendor="X.Org Foundation"
[ 15.823] compiled for 1.9.0, module version = 2.12.0
[ 15.823] Module class: X.Org Video Driver
[ 15.823] ABI class: X.Org Video Driver, version 8.0
[ 15.823] (EE) module ABI major version (8) doesn't match the server's version (10)
[ 15.823] (II) UnloadModule: "intel"
[ 15.823] (II) Unloading intel
[ 15.823] (EE) Failed to load module "intel" (module requirement mismatch, 0)

... It's reverting to the VESA driver because it was compiled for an older version of X.

Disabling DRI as suggested by Norbert works, but I haven't tested it enough to notice the difference. I don't know what DRI does.

The right way to fix this would be to disable the page-flipping and recompile the driver. The bugzilla bug linked by mkkot tells what to change. I might give it a try, but I don't really know what I'm doing.

If someone who does know what they're doing wants to make the change and update to xf86-video-intel in extra, I would greatly appreciate it.