Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21918 - [ati-dri] Vertical colored stripes on chipset RS482 (Xpress 200M Series) with/out KMS

Attached to Project: Arch Linux
Opened by Allaedine El Banna (wedjat) - Monday, 29 November 2010, 12:05 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 03 May 2011, 17:19 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

With the graphical chipset Xpress 200M Series (Radeon Xpress 1150), booting with KMS gives you sometimes, as soon as Xorg boots, a screen with many vertical colored stripes. You cannot Alt+Sys+K or do anything.

With
ati-dri 7.8.2-3,
libgl 7.8.2-3
xf86-video-ati 6.13.2-1

i can use the "nomodeset" option to disable KMS and boot correctly. With the new versions, xorg refuses to boot :
Backtrace:
0: /usr/bin/X (xorg_backtrace+0x28) [0x49f1a8]
1: /usr/bin/X (0x400000+0x60239) [0x460239]
2: /lib/libpthread.so.0 (0x7fbee425d000+0xf1c0) [0x7fbee426c1c0]
3: /usr/lib/xorg/modules/extensions/libglx.so (0x7fbee2069000+0x38868) [0x7fbee20a1868]
4: /usr/bin/X (FreeClientResources+0xee) [0x44a2ee]
5: /usr/bin/X (FreeAllResources+0x49) [0x44a3a9]
6: /usr/bin/X (0x400000+0x21305) [0x421305]
7: /lib/libc.so.6 (__libc_start_main+0xfd) [0x7fbee31e2c4d]
8: /usr/bin/X (0x400000+0x20e79) [0x420e79]
Segmentation fault at address 0x75

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting

Additional info:
* package version(s) :
ati-dri 7.9-1
libgl 7.9-1
xf86-video-ati 6.13.2-2

i tried also with the last kernel and xorg packages :
kernel26 2.6.36.1-3
xorg-server 1.9.2-2
libdrm 2.4.22-1

but these don't seem to give any problems.

Steps to reproduce :
just boot your system with KMS enabled, you will have vertical colored lines very often.
Without KMS, X refuses to boot.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 03 May 2011, 17:19 GMT
Reason for closing:  Works for me
Additional comments about closing:  no further comments from the reporter. nothing reported upstream,
Comment by Federico Chiacchiaretta (baghera) - Monday, 29 November 2010, 13:35 GMT
When I had vertical stripes on my old Ati radeon x700, it was an hardware fault, I had to replace my graphics card.
Comment by Allaedine El Banna (wedjat) - Monday, 29 November 2010, 14:32 GMT
When i used to work under the 2.6.26 kernel, with mesa or the proprietary fglrx driver, i never had any problems.
Comment by Allaedine El Banna (wedjat) - Monday, 29 November 2010, 15:27 GMT
When i used to work under the 2.6.26 kernel, with mesa or the proprietary fglrx driver, i never had any problems.
Comment by Andreas Radke (AndyRTR) - Monday, 29 November 2010, 15:28 GMT
If the latest packages don't give any problem what wrong now? If the bug has gone feel lucky.
Comment by Allaedine El Banna (wedjat) - Monday, 29 November 2010, 15:31 GMT
Sorry, i wanted to mean that with the latest versions of these packages :
ati-dri 7.9-1
libgl 7.9-1
xf86-video-ati 6.13.2-2

i have vertical stripes when i use KMS, and cannot start X without KMS. I am forced to ignore any updates of these packages and stay to the older versions quoted in the topic.

However, I can upgrade any other packages such as kernel26 or xorg-server.
Comment by Guillermo (gmenguez) - Monday, 29 November 2010, 16:18 GMT
Try booting with drm_kms_helper.poll=0 in kernel cmdline, it worked for me.
Comment by Andreas Radke (AndyRTR) - Monday, 29 November 2010, 16:19 GMT
Please stay with the latest packages and let's try to solve your issue. Please disable dri usage in your xorg.conf and fond out that way if mesa causes your problem.
Comment by Allaedine El Banna (wedjat) - Monday, 29 November 2010, 19:28 GMT
Unfortunately, the option drm_kms_helper.poll=0 doesn't seem to help. :(

However, by disabling dri usage it works better. Despite of having to use 'nomodeset' again, i can start X without any problems. I have no more 3d acceleration (100FPS instead of 1000FPS with glxgears) but at least, it works.

By the way, if i disable "dri" and use no kernel options (no "nomodeset") i see the vertical stripes at boot, only for 5 seconds, before having kdm displayed. Then, i have the same results.
If I start for example KDE Desktop Effects, i will see again the vertical stripes for 5 seconds...and return to kdm ! :)
Comment by Sagar Khadilkar (sagar_k) - Tuesday, 07 December 2010, 09:49 GMT
have same problem with ati xpress 200.
Comment by Andreas Radke (AndyRTR) - Saturday, 18 December 2010, 11:18 GMT
Please test mesa 7.10 in testing.
Comment by Andreas Radke (AndyRTR) - Sunday, 30 January 2011, 10:53 GMT
State? I cannot confirm this with my X200m card and recent KMS in kernel 2.6.37/Xorg 1.9.x/Mesa7.10. If you don't provide further informations or an upstream report to follow I'm going to close this one.
Comment by Allaedine El Banna (wedjat) - Monday, 14 February 2011, 05:35 GMT
Sorry for my late AndyRTR ! I request the opening because I just tested with this configuration :
- kernel 2.6.37-5
- xorg-server 1.9.4-1
- libdrm 2.4.23-1
- mesa 7.10.0.git20110206-2
- ati-dri 7.10.0.git20110206-2
- xf86-video-ati 6.14.0-1
- libgl 7.10.0.git20110206-2

To summarize the situation :
- 3D isn't working at all (if you execute for example extremetuxracer the screen freezes with the same colored stripes, and it never works,
- the 2D situation is the same. You need to test several times (around 3 or 4), to see vertical stripes after booting.
So i'm currently forced :
- to disable DRI,
- to disable KMS by adding 'nomodeset' to boot options.

So, what should we do ? Should we follow this bug here, or should i open an upstream bug to xorg developers ?

Regards,
Comment by Andreas Radke (AndyRTR) - Monday, 14 February 2011, 19:02 GMT
I cannot confirm this. My X200m driven notebooks works well.

Use KMS because it's the only recommended mode nowadays. Test with DRI disabled to locate if the striped are caused by 3D rendering. Bring it upstream to the proper Kernel or Xorg part. I can't help out here. So either provide an upstream report to follow or I will soon close this again.
Comment by Allaedine El Banna (wedjat) - Tuesday, 15 February 2011, 21:57 GMT
You're right AndyRTR, it's working when i use KMS (i.e removing "nomodeset" from the kernel options) AND disabling DRI. However, as always, every time i see the vertical stripes just when i quit my desktop environment to shutdown or reboot my computer, in fact just right before returning to KDM. But after 7 seconds, it really power off or reboot so it's not a real problem (but still...well, not perfect :)).

So, the major bug is today that you still cannot use DRI with this chipset (Radeon Xpress 1150) on my Dell Inspiron 1501, or any 3d function. Any "3d program" makes your display totally crashes with the vertical stripes, with major consequences (you're forced to shutdown the machine, loss of KDE configuration after rebooting...). Can you confirm that, or is 3D working on your laptop ?

Well, i can produce a bug to Mesa and/or kernel developers for that. Do you want me to link any bug report i could make there to the bug i reported here ?

Regards,
Comment by Andreas Radke (AndyRTR) - Wednesday, 16 February 2011, 05:53 GMT
when the bug only appears when using ati-dri it should be in mesa. you should file a bug for mesa upstream and post a link to follow it here.

maybe you can try to replace kdm with gdm/lxdm for testing. it may also be a bug in kdm if doesn't happen in the desktop once you are logged in.
Comment by Andreas Radke (AndyRTR) - Thursday, 24 March 2011, 18:17 GMT
state?
Comment by JM (fijam) - Tuesday, 03 May 2011, 10:07 GMT
No update from the submitter since February. No upstream follow-up. Possible candidate for closing.

Loading...