Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21841 - [kernel26] 2.6.36.1-3 Error when unmounting USB drives

Attached to Project: Arch Linux
Opened by György Balló (City-busz) - Friday, 26 November 2010, 19:16 GMT
Last edited by Tobias Powalowski (tpowa) - Saturday, 19 February 2011, 17:21 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
After I updated to kernel 2.6.36, when I unmount USB drives, my desktop disappear, and I get the following message:
"BUG: unable to handle kernel NULL pointer dereference at 00000014"

Additional info:
* package version(s)
kernel26 2.6.36.1-3
udisks 1.0.1-5
gnome-disk-utility 2.32.0-2
gvfs 1.6.6-1
nautilus 2.32.1-1
* config and/or log files etc.
The relevant part of everything.log attached.

Steps to reproduce:
Unmount an USB drive in Nautilus.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Saturday, 19 February 2011, 17:21 GMT
Reason for closing:  Fixed
Comment by György Balló (City-busz) - Friday, 26 November 2010, 19:46 GMT
After I removed tracker package, this bug disappear.
Comment by György Balló (City-busz) - Friday, 26 November 2010, 19:59 GMT Comment by Maxwell Draven (Ravenman) - Tuesday, 07 December 2010, 21:23 GMT
I have this issue too ... not unmounting, mounting the USB stick. I don't have GNOME, I have lastest KDE.
Comment by Leonid Isaev (lisaev) - Monday, 13 December 2010, 19:56 GMT
I can't reproduce either your oops, or the one on the kernel.org bugzilla.
Kernel: 2.6.36.2.
Media: FAT32 usb card (android phone).

Also, how is DE relevant to a kernel bug?
Comment by György Balló (City-busz) - Monday, 13 December 2010, 20:41 GMT
It's only happens when tracker installed and tracker-miner-fs running:
http://www.archlinux.org/packages/community/i686/tracker/
The tracker-miner-fs starts automatically when I log in to GNOME Desktop.
Comment by Leonid Isaev (lisaev) - Monday, 13 December 2010, 21:55 GMT
OK. But this what confused me in the first place, because the Debian bug report does not mention the tracker...
Comment by Ramses de Norre (Ramses_de_Norre) - Friday, 17 December 2010, 08:47 GMT
I don't have that tracker either.
Comment by György Balló (City-busz) - Saturday, 19 February 2011, 17:02 GMT
Now I tested again with kernel26 2.6.37-6, tracker 0.10.0-1, and I no experienced this error, so you can close this bug.

Loading...